EM12-G (FW: EM12GPAR01A21M4G) spontaneous hangups

Это все, что вам нужно знать

Let us speak english, that my help to solve our problem

Привет!
Это я написал. Это гамно уже задолбало. Причем такие отвалы некоторых обладателей этого чуда (Шато) вполне устраивают.
Дмитрий.

Добрый день! А содержимое смс какое? Если прием смс не принципиален, попробуйте залочить модуль в PS через AT+QCFG=“servicedomain”,1

Содержимое смс в inbox типа ??? ??? ??? 12*25. Кириллические символы не отображаются.
Но один френд уже попробовал залочить.

AT+QCFG=“servicedomain”,0,1 лочит модем в CS (голос и SMS в 2G/3G). Пакетная сеть естественно оказывается отключена. А команда без параметров (AT+QCFG=“servicedomain”) просто возвращает текущее значение.

Что касается смс с кириллицей, то прочитайте их командами. AT+CMGR=<номер слота>. Если включен текстовый режим (AT+CMGF=1), то модуль выдаст hex-строку в кодировке UCS2. Декодировать можно тут http://crypt-online.ru/crypts/text2hex/ (выбрать UTF8). Возможно сеть сообщает какую-то причину для отключения

Спасибо. Я уже пробовал. Получается вот так:
Phone: 0820053000240314011000240b34003000240 Timestamp: Mar/18/2041 10:41:04 GMT +0,
т.е. очень похоже, что тело смс попадает в поле Phone, дата вообще кривая, а поле Message оказывается пустым.

Нет, просто опсос хочет дополнительных денег для раздачи по wifi в моем случае (я читал эти смс-ки на другом модеме Huawei).
После того как выставил SMS Receive Enable No - на вкладке lte1 появился красный транспарант —transaction error, а в логе сообщение: lte1 mbim: error: >>> E service: connect, command: visible providers, error: 1

Доброго всем дня.
У меня точно такая же проблема с отвалами EM12-G
Ребята, скажите пожалуйста, как у Вас работает EM12-G если принудительно оставить только 2 несущих.
Уточняю, использую Mikrotik RBM11G
У меня ситуация следующая, когда модем работает с 3CA (B1+B3+B20) общая ширина получается 50 МГц - в таком режиме происходят отвалы:
Oct/11/2021 16:31:04 lte,async,event lte1: +CGEV: NW DETACH

Если модем принудительно переключить в 2CA (B1+B20) - то модем не отваливается.

Так же в пользовании есть Mikrotik Chateau с модемом EG18-EA это спешиал эдишн для нашего местного мобильного оператора, с данным девайсом в режиме 3CA (B1+B3+B20) отвалов нет, скорость 240/40 Mbit/s

1 Like

У меня EG12-EA. Оставлял только b3 и b7. Именно оставлял, а не лочил определенные сектора.
Всё равно происходят отвалы. Причем отвалы просходили как во время минимальной нагрузки на модем (ночью), так и при максимальной нагрузке (запуске Speedtest от Ookla).
Предположения разные.

  • “мусор” в INBOX sms;
  • переполнение INBOX sms;
  • периодическое падение качества сигнала БС и последующий перегрев чипа;
  • просадка питания модема (в обвязке модема на фото материнской платы не нашел ни одного электролитического конденсатора большой емкости, да и самого стабилизатора DC, хотя рекомендуемая схема обвязки для модема имеется:
    image

Мда… данное чудо (EM12-G) еще и ведет себя по разному.
Странно только одно, я писал в суппорт Mikrotik, описал все ситуацию с модемом EM12-G и попросил их проверить, нет ли такой же проблемы с EG12-EA в Mikrotik Chateau.
На этот вопрос они ответили следующее, что мол такого рода проблемы не возникали и к ним в суппорт с такими жалобами не обращались.

Я уже написал всем и вся по поводу данной проблемы, в Quectel отправил QXDM логи.

Судя по фото https://www.mikrotik.ru/katalog/katalog/components/routerboards/mikrotik-rbm11g
в RBM11G с модемом EM12-G сделано всё по-взрослому (и обвязка есть со стабилизаторами и кондёрами, и радиатор на чипе).

Лично я пока в техподдержку Mikrotik не обращался. Пока только получил ответ и суппорта Quectel:


Посмотрим, что посоветуют. А потом уже с этим в Mikrotik.

Скажите пожалуйста, перед отвалом, есть ли у Вас данная строка в логе
lte,async,event lte1: +CGEV: NW DETACH
?

В принципе, данная строка, по крайней мере в моем случае означает, что команда пришла на модем от оператора о прекращении сессии, но почему не понятно.

С EG18-EA такого нет, хотя модем работает с той же внешней антенной, сигналы одинаковые что с EM12-G и с EG18-EA

Нет, такой строки нет. Но это не значит, что ничего не происходит на физическом или канальном уровне - просто в лог не записывается и всё, имхо. У меня ROS 7.1 rc4.

С другим оператором пробовали?
Какая полная версия прошивки в модуле? Проверьте через AT+QGMR.

Скажите пожалуйста, у Вас логгирование LTE /system logging add topics=lte включено ?

Так чем не причина для временной блокировки? Проблема только с одним оператором проявляется или на всех прочих тоже?

Нет, с другим оператором не пробовал, так как 3CA поддерживает только один оператор в моем районе, у всех остальных только 2CA, как я уже писал выше, в режиме 2CA работает нормально, отвалов замечено не было.

EM12GPAR01A21M4G_01.004.01.004

[admin@MikroTik] > /interface lte at-chat lte1 input=“AT+QGMR”
output: EG12EAPAR01A10M4G_01.001.01.001
OK

[admin@MikroTik] >