EM12-G (FW: EM12GPAR01A21M4G) spontaneous hangups

Bug description:
The modem occasionally hangups for 5 sec - 5 minutes, it’s still working and accessible by AT COM-port, shows that it’s connected and registered at BS, but traffic is not passing through. For example, on the Keenetic Viva (KN-1910) you may see the modem is “connected without internet access” and DL speed is “0”. In most cases bug appears at high load, i.e. speed test, and speed at least 50mbps.

Solution:
DOWNGRADE FW to EM12GPAR01A20M4G.

For Quectel developers:
I will be glad to answer any specific questions that will help you to localize the bug in tons of code.

Sincerly,
Konstantin Belov.

1 Like

Hi kostyabelov,
Thanks for your query in Quectel forums.
Will the problem be solved by updating to EM12GPAR01A20M4G, can you tell me your detailed test steps and methods?
thanks.

Test environment:

New EM12-G with last 21 FW, multi-bands MIMO antenna, NGFF to USB3 adaptor, connected to:

  1. Laptop;
  2. Desktop;
  3. Keenetic Viva KN-1910.

Distance to BS: 5.4km
Operator: TELE2 (Russian Federation)
Bands: B3 (BW: 10MHz), B20 (BW: 5MHz)
Response from EM12-G:
at+qeng=“neighbourcell”
+QENG: “neighbourcell intra”,“LTE”,1573,10,-10,-86,-58,0,-,-,-,-,-
+QENG: “neighbourcell intra”,“LTE”,1573,11,-14,-89,-65,0,-,-,-,-,-
+QENG: “neighbourcell inter”,“LTE”,6175,34,-12,-82,-61,0,-,-,-,-
+QENG: “neighbourcell inter”,“LTE”,6175,3,-13,-83,-61,0,-,-,-,-

OK
at+qeng=“servingcell”
+QENG: “servingcell”,“NOCONN”,“LTE”,“FDD”,250,20,A87DE0C,10,1573,3,3,3,4012,-86,-11,-57,19,-,140,-

OK

Bug appears:
B3+B20, or just B3 with 2 antennas (Full Speed up to 100(70)Mbps)
Bug not appears (or appears seldom):
B3+B20, or just B3 with 1 antenna (diversity is off) (Half speed up to 50(35)Mbps)
B20

Sincerly,
Konstantin Belov.

1 Like

Hi Konstantin,

thanks for bringing this up. I have the same issue, but with a different network provider - Yota(Megafon).
I’m using EM12-G in Mikrotik’s RBM33G, but the issue also appears when modem is used in PC via NGFF adaptor. I can reproduce it with almost 100% success by doing a speedtest at http://yota.speedtestcustom.com/ when the speeds exceed 80Mbps.
There is a graph showing the speed, and once the graph starts showing the flat line without any peaks, I know that the modem has lost the internet connectivity.

@Kerr.Yang-Q Unfortunately, this issue does not stop with downgrade to EM12GPAR01A20M4G for me.
I’ve downgraded a bit further, and it seems that the last FW, that is working correctly is EM12GPAR01A18M4G.
Could you please compare what was done between 18 and 19 firmwares to start causing such behaviour?

Thanks,
Fedor

I confirm this problem. I have an Em12-G modem connected to a Mikrotik RBm33g, firmware EM12GPAR01A21M4G. Operator Megafon, Russia.
When testing the speed of speedtest.net, approximately over 50 megabits (the exact speed cannot be found out). The modem stops receiving traffic. (sorry for bad english)

Hi @Kerr.Yang-Q, here is the QXDM log I’ve captured while testing the EM12 (FW21) when doing speedtest and observing the issue. Not sure if this is the right thing, but please feel free to ask me to do more tests.

Hi kostyabelov,
Thanks for your query in Quectel forums.
Thank you for providing the steps to test the problem, I will give you the result as soon as I finish the local verification.
thanks.

Hi fred_com,
You can send e-mail to support@quectel.com to get local FAE support,thanks.
Is the EM12GPAR01A20M4G you are using the official version?
thanks.

Hi Kerr.Yang, I’ve sent the email to them.
I’m using EM12GPAR01A21M4G firmware which I got from other forum. If you think this issue is caused by compromised firmware, please provide the trusted one, I’ll be happy to test it.

Is work being done to fix the problem? Is there any solution now?

I confirm all of the above, the internet really disappears at speeds above 80 mbps.
RBM33G + EM12-G +M2 to USB 3.0
Distance to the base station: 2.49 km
Carrier: MTS (Russian Federation)
Bands: B3 (BW: 15 MHz)
I appeal to Quectel when will the problem be solved? How long can we wait? Is the EM12-G discontinued? Why is there no work being done?
I know many people who have given up EM12-G for another because of the problems described above. Unfortunately, I cannot recommend it to my customers until this problem is corrected.

P.S - I would like to add the problems are observed on the latest firmware:

Name: EM12GPAR01A21M4G_01.003.01.003.zip

Size: 107649752 bytes (102 MiB)

CRC32: 6C680A38
SHA256: 634593245E34267057421EF6EE0A6C8523B6FCBC9850042F7EA0A2ED7C534184
SHA1: 4E0DBD4C46F7B93099891E59E7587CD846919013

The drop in speed occurs when one of the eight sensors reaches 40 degrees Celsius

I do not advise to buy this modem because of speed problems!
Why buy a 600 mbps modem if it only works up to 80 mbps. Quectel won’t do anything to fix it if it could be fixed, it would be fixed by now. I do NOT recommend it for purchase!!!

I agree. Quectel must stop selling the piece of bug at least temporary until fixing the problem. The device is non-working, waisted money for customers.

Adding oil to the fire:
Tring this for YOUR OWN RISK:

  1. If you set network mode to RNDIS: at+qcfg=“usbnet”,3, modem “become a BRICK”. The only way to unbrick it is to put it in QDL9008 mode connecting USB BOOT pin to ground, power up modem and flash FW 19 and lower.
  2. Modem hangups when flashing by Sahara protocol in normal mode. The flash process can be then succesfully completed after power reset, QFlash writes EDL (Emergency Loader) and flashing process completes successfully.

So the position of Quectel (at least I was told so): we are WHITE AND FLUFFY, the problem in QUALCOMM MODEM FW (NON-HLOS,ubi). We submit a bug to Qualcomm (it was about two monthes ago) but they still did not response.

I regret that I did not send it back to China right adter new year when I got it.

Without any hope,
Konstantin Belov.

BTW, the common thing for all posts above is MNC: 250,
maybe the size of Quectel byte is 249? :slight_smile:

I am watching the seller I bought from and noticed that his sales have dropped a lot, despite the fact that he had to lower the price due to low demand and the problems described above. While they don’t know everything yet they need to sell quickly, which I will do not for slow and advise others to do the same.

Interruptions of about 40 seconds.
And there is no disconnection from the network, as you can see in the screenshot, but the Internet at the moment is not available for about 40 seconds.


Temperature at the moment of rupture
output: OK
+QTEMP: “xo_therm_buf”,“30” +QTEMP: “mdm_case_therm”,“31” +QTEMP: “pa_therm1”,“29” +QTEMP:
“tsens_tz_sensor0”,“34” +QTEMP: “tsens_tz_sensor1”,“34” +QTEMP: “tsens_tz_sensor2”,“33”
+QTEMP: “tsens_tz_sensor3”,“34” +QTEMP: “tsens_tz_sensor4”,“34”

Even more…
The modem in module is fully connected during those 40 secs. You may try “AT+QPING=1,“8.8.8.8”,10” via AT port and see that the modem in module still working. The problem in network interface.

Проблема не в RBM33G?
Кстати если его подключить в miniPCI-e через переходник через некоторое время он сам переключается в usb 2.0 после этого пропадают уровни сигналов, перестают работать AT команды, но при этом интернет есть.
Тоже самое и в порту usb 3.0, если переключить в usb 2.0
В usb 3.0 через переходник M2 usb 3.0 под две симки нормально работает

1 Like

Другой не пробовали ?