EC25 MQTT URC Unstable Issues

I’m using this 4G Module and MQTT. In my testing, the URC replies is not stable. The response data sometimes don’t reply the full data. And after a few try, it only reply the correct data format. On smaller data, there isn’t this issue. I’m sending about 440 characters.

The buffer returns something like this or a cut off data which I sent.

URC: [59, 0, 0, 0, 30, 59, 18, 13, 10, 79, 75, 13, 10]

Is there any new firmware updates which fixes this issue?

The version I’m using is this.



Anyone can help? Or have information on what’s the latest firmware, how to get it and how to flash?

Hi the latest firmware is EC25EUXGAR08A11M1G_20.003.20.003,do you need?

Hi yes I need it.
Can I check the change log of the updates?
Will the MQTT be more stable in the newer version?

Yes, I have looked at the upgrade log and it contains some optimizations regarding MQTT.

Thanks, I’ve sent you a PM. Can I get the upgrade log too?

Yes,I send it to you by e-mail.

I’ve tried to flash the firmware.
After flashing, I check on my Device Manager and I only have “Quectel USB DM Port”.
I don’t see “AT Port”.
I tried the following but nothing works. I am not able to communicate over serial with the device now.

  1. Restart power
  2. Reinstall drivers
  3. Reflashing

What should I do?

Can you show me a screenshot of the driver you installed?

Please see the attached. It seems like maybe the newer version disabled the other ports or even when restarted, it’s in firmware upgrade mode?

Hi,In computer Settings, Apps and Programs, searching for “quectel” will bring up installed drivers, as shown in the image.

Hi I’ve attached in this response.

Before upgrading the firmware, there was 3 ports.

  1. AT port
  2. DM port
  3. NMEA port

After successful flashing it only left with DM port.

I tried to install a newer firmware downloaded from here but it’s still the same.
Could it be the firmware provided is not correct?

Hello, I can’t find your email, could you please give me again? In addition, could you please show me the screenshot of the firmware version you received? I’m going to send you this version to try again. EC25EUXGAR08A09M1G

I have message you my email.

Hi, I have tried and updated the firmware but there is still only 1 DM port.
Please see the attached image. I selected the file “prog_nand_firehose_9x07.mbn” when click “Load FW Files”. Did I flash correctly?

Going through the forums, one possible issue could be the newer firmware updated some settings which disabled some USB ports. Could be due to remapping of memory addresses or ignoring old configurations. I’m just guessing as I do not have the time to investigate.

It’s such a unpleasant experience and now my module cannot even work normally.
I am sure I’m not the first to experience this issue but somehow I cannot find any solution. And Quectel Support is not very helpful.

There’s so many versions, and firmware has to be requested and sent through email. Why is that? Why isn’t there a page for individual modules and all the firmware download with change logs? Why do we have to comb the forum reading issues and only realizing the issue is still not closed?

I’m very sorry, we are trying to solve this problem, I have not encountered this kind of problem before, please give me some time.

Thank you. Please let me know if you need any more information on my side.