Sending AT commands to the RM520N-GL

I’m using a RM520N-GL with the M.2 EVB. I have to send AT commands and receive responses. Currently I’m using the USB-C interface to make it work. I would like to know if it is possible to use other interfaces (especially microUSB) to send AT commands? I’ve tried using Ethernet as mentioned here, but couldn’t get it to work. RM502Q-AE and at+qeth=“eth_at” - IoT Modules / 5G Module - Quectel Forums. Any help would be highly appreciated.

Dear @mpmic
Why do you want to use microUSB? Did you output the USB port on your device?

Hello Silvia,
I would like to use microUSB as I have better control over it, to disconnect it remotely for example. Connecting to the board using microUSB, I see the device “CP2102 USB to UART Bridge Controller”, and that the drivers for this device are not installed. I tried installing the drivers that come with the Quectel M.2 EVB Kit Support Package V1.7, but to no avail.

μUSB connector is USB-TO-UART Interface.
Modem’s USB interface is exposed on the Type-C connector.
That should be explained in EVB manual.

@jfrog, thank you for your swift reply. I’ve tried to get it to work using ethernet also, according to the manual the following AT commands are used to set the module into WLAN/Ethernet function mode:
:black_circle: AT+QCFG=“data_interface”,1,0: switch the module to PCIe interface.
:black_circle: AT+QCFG=“pcie/mode”,1: set the module to PCIe RC mode.
:black_circle: AT+QETH=“eth_driver”,“R8168”,1: load the driver for RTL8111H TE-A.
:black_circle: AT+QETH=“eth_at”,“enable”: enable the driver.

I’ve followed the steps and entered in the commands above, the green light on the RTL8111H TE-A blinks. How can I send AT commands via the ethernet now? I’ve used PuTTY to send AT commands using telnet, to the given IP address at port 1555 (from RM502Q-AE and at+qeth="eth_at"), but the connection was refused.

Additionally, the RG520N&RG5x0F&RM5x0N Series AT Commands Manual says “The main UART port and two USB ports (USB modem port and USB AT port) support AT command communication and data transfer”, does this mean I can use the microUSB port? Any help would be appreciated.

My understanding you need a client program as mentioned in RM502Q-AE and at+qeth="eth_at"
For UART access you will need to find and install the driver for CP210x.