RM500Q connection to Linux


I am trying to connect RM500Q to my raspberry pi 4. I got the linux drivers and I was able to make them fine. I am trying to run QconnectManager but I get error with dhcp. Where do I need the dhcp? Can I disable it somehow or can I fix this error otherwise? Here are some logs I gathered:

Used system:

PRETTY_NAME=“Raspbian GNU/Linux 10 (buster)”
NAME=“Raspbian GNU/Linux”
VERSION=“10 (buster)”

Command: sudo ./quectel-CM
[10-08_15:11:45:342] Quectel_QConnectManager_Linux_V1.6.0.16
[10-08_15:11:45:344] Find /sys/bus/usb/devices/1-1.3 idVendor=0x2c7c idProduct=0x800, bus=0x001, dev=0x007
[10-08_15:11:45:345] Auto find qmichannel = /dev/cdc-wdm0
[10-08_15:11:45:345] Auto find usbnet_adapter = wwan0
[10-08_15:11:45:345] netcard driver = qmi_wwan, driver version = 5.10.60-v7l+
[10-08_15:11:45:345] ioctl(0x89f3, qmap_settings) failed: Operation not supported, rc=-1
[10-08_15:11:45:346] Modem works in QMI mode
[10-08_15:11:45:371] cdc_wdm_fd = 7
[10-08_15:11:45:469] Get clientWDS = 15
[10-08_15:11:45:501] Get clientDMS = 1
[10-08_15:11:45:533] Get clientNAS = 4
[10-08_15:11:45:565] Get clientUIM = 1
[10-08_15:11:45:597] Get clientWDA = 1
[10-08_15:11:45:629] requestBaseBandVersion RM500QGLABR11A03M4G
[10-08_15:11:45:757] requestGetSIMStatus SIMStatus: SIM_READY
[10-08_15:11:45:789] requestGetProfile[1] 5g.sktelecom.com///0
[10-08_15:11:45:821] requestRegistrationState2 MCC: 450, MNC: 5, PS: Attached, DataCap: LTE
[10-08_15:11:45:853] requestQueryDataCall IPv4ConnectionStatus: DISCONNECTED
[10-08_15:11:45:853] ifconfig wwan0
[10-08_15:11:45:861] ifconfig wwan0 down
[10-08_15:11:45:885] requestSetupDataCall WdsConnectionIPv4Handle: 0x1754e430
[10-08_15:11:46:013] ifconfig wwan0 up
[10-08_15:11:46:020] busybox udhcpc -f -n -q -t 5 -i wwan0
udhcpc: started, v1.30.1
udhcpc: sending discover
udhcpc: sending discover
udhcpc: sending discover
udhcpc: sending discover
udhcpc: sending discover
udhcpc: no lease, failing

Command: ifconfig wwan0
wwan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet netmask broadcast
ether 5e:c6:28:30:0f:56 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 350 bytes 74917 (73.1 KiB)
TX errors 55 dropped 0 overruns 0 carrier 0 collisions 0

Please try it with the qmi driver I sent via email.

Thank you Isaac for the file.

I installed the drivers but there was no change. Still exacty same error occurs. Old drivers were dated 20/7/2020.
Do you have any other suggestions I should try to do?

Please switch to ECM mode for testing through at+qcfg=“usbnet”,1 command.

Thank you for the response.

ECM seems to work for me. Now wwan0 turned to usb0 when I run ifconfig. For some reason the IP address is and not the IP from my sim card BUT when I try to ping this it doesnt answer and instead pinging my sim card IP address works. I can also ping back from my device to other system.

Is there any limitations for using ECM mode? If not, then I think this issue can be closed and thank you for the help!

Hello Mr. Wang,
I’m new here and got a question regarding QMI. I got a RM500Q-GL working on a RaspPi 4 with Atlantixx Networks 5G Hat (latest ubuntu server OS) by building modem-manager, QMI-lib and utils an Mbim lib and utils from the latest stable releases. So far so good, but I achieve only 150Mbps down- and 20Mbps up-stream, while 1Gbps up and down should be possible from mobile network site (5G campus network). Is there a newer QMI version with special adaptions from your site? Should I take care for anything else? Thank you.


I am trying with modemmanager_1.16 , libqmi_1.28.6-1 & libmbim_1.24.8-1 on arm, though compilation is through bearer is not connecting.
Can you share the package versions of modem-manager, qmi-lib , utils , mbim lib & utils which you were able connect .


Hi Isaac,

Would you be able to send me the drivers for RM500Q, RM510Q, and RM502AE?
Could you please advise which one do I need GobiNet Driver or QMI_WWAN?


It is recommended that you use the latest tool version to test.

1 Like

QMI_WWAN is the priority. the drivers I will send them via email, please ckeck it.

1 Like

Dear Isaac.Wang-Q,

I am seeking your help to work with Quectel RM500Q-AE on Linux OS. I don’t have any prior experience on configuring Quectel Modem. It will be a great help for me if you have any detailed guideline to start with in Linux Environment.

Thank you.

Dear @f.f
I will share USB driver to you, please refer to the use guide.
We don’t have any guide about how to start with linux, the module just a component in your device, you need to control it via your MCU.

Dear @silvia

Thanks a lot for your help. I will be waiting for your feedback. Thank you.

Dear @f.f
I have sent to you, please check.