Registration denied


I have the problem with the network registration of my Wislink2011 from Rakwireless. My SIM card is from Vodafone Australia. The module and SIM card information are still shown in the QNavigator software. I still can use GPS function. Please help me with this issue. Thank you for reading

Are you in a Vodafone NB-IoT coverage area?

What does the AT command AT+COPS? return? It can take more than a minute to return a result.

Hi, thanks for the reply. Yes, I’m in a Vodafone NB-IoT area, I guess. Please refer to the attached image.

Here is the command and its returns:
[2022-11-05 10:09:02:305_R:] AT+COPS=?

[2022-11-05 10:09:34:096_R:] +COPS: (3,“505 16”,“505 16”,“50516”,0),(3,“Telstra Mobile”,“Telstra”,“50501”,9),(1,“Optus AU”,“Optus”,“50502”,9),(1,“Vodafone AU”,“Voda AU”,“50503”,9),(0,1,2,3,4),(0,1,2)

[2022-11-05 10:09:34:096_R:] OK

You’ve got Vodafone NB-IoT signal there, so that’s OK. What have you got set as your APN?

thanks, I have used the following command:
And then, I reset the module, still “not registered” or “registration failed”.

Here’s are the AT commands and returns:
/* Use AT+CREG? /AT+CGREG? to query the network registration status. */
[2022-11-05 10:53:28:509_S:] AT+CREG?
[2022-11-05 10:53:28:522_R:] AT+CREG?

[2022-11-05 10:53:28:522_R:] +CREG: 0,3

[2022-11-05 10:53:28:522_R:] OK
[2022-11-05 10:53:28:539_S:] AT+CGREG?
[2022-11-05 10:53:28:551_R:] AT+CGREG?

[2022-11-05 10:53:28:551_R:] +CGREG: 0,4

[2022-11-05 10:53:28:551_R:] OK

/* Make sure the Antenna is connected and the network is normal */

For your convenience, I attached other AT commands here:
/* Use AT+CPIN? to query the SIM card status : SIM card inserted or not, locked or unlocked */
[2022-11-05 10:59:10:463_S:] AT+CPIN?
[2022-11-05 10:59:10:483_R:] AT+CPIN?

[2022-11-05 10:59:10:483_R:] +CPIN: READY

[2022-11-05 10:59:10:483_R:] OK

/* Use AT+CSQ to query current signal quality */
[2022-11-05 10:59:10:510_S:] AT+CSQ
[2022-11-05 10:59:10:531_R:] AT+CSQ

[2022-11-05 10:59:10:531_R:] +CSQ: 13,99

[2022-11-05 10:59:10:531_R:] OK

/* Use AT+CREG? /AT+CGREG? to query the network registration status. */
[2022-11-05 10:59:10:564_S:] AT+CREG?
[2022-11-05 10:59:10:581_R:] AT+CREG?

[2022-11-05 10:59:10:581_R:] +CREG: 0,3

[2022-11-05 10:59:10:581_R:] OK
[2022-11-05 10:59:10:599_S:] AT+CGREG?
[2022-11-05 10:59:10:616_R:] AT+CGREG?

[2022-11-05 10:59:10:616_R:] +CGREG: 0,4

[2022-11-05 10:59:10:616_R:] OK

/* Use AT+COPS? to query current Network Operator */
[2022-11-05 10:59:10:652_S:] AT+COPS?
[2022-11-05 10:59:10:677_R:] AT+COPS?

[2022-11-05 10:59:10:677_R:] +COPS: 1

[2022-11-05 10:59:10:677_R:] OK
Please help me with this. Thank you.

What is the firmware version of the module currently in use?


pelease execute the command above,then print and add attachment

The firmware is BG96MAR02A07M1G.
Please check the attached commands:
[2022-11-05 12:48:05:939_R:] AT+CPIN?

[2022-11-05 12:48:05:939_R:] +CPIN: READY

[2022-11-05 12:48:05:939_R:] OK

/* Make sure the Antenna is connected and the network is normal */
[2022-11-05 12:48:17:099_S:] AT+CIMI
[2022-11-05 12:48:17:108_R:] AT+CIMI

[2022-11-05 12:48:17:108_R:] 505038320117711

[2022-11-05 12:48:17:108_R:] OK
[2022-11-05 12:48:26:601_S:] AT+CFUN=0
[2022-11-05 12:48:26:614_R:] AT+CFUN=0

[2022-11-05 12:48:26:677_R:] DSR:0 CTS:0 (RI:1) DCD:0

[2022-11-05 12:48:26:682_R:] OK

[2022-11-05 12:48:26:682_R:] +QSIMSTAT: 1,0

[2022-11-05 12:48:26:797_R:] DSR:0 CTS:0 (RI:0) DCD:0
[2022-11-05 12:48:39:501_S:] AT+QCSCON=1
[2022-11-05 12:48:39:510_R:] AT+QCSCON=1

[2022-11-05 12:48:39:510_R:] OK
[2022-11-05 12:48:46:806_S:] AT+CFUN=1
[2022-11-05 12:48:46:819_R:] AT+CFUN=1

[2022-11-05 12:48:47:012_R:] OK

[2022-11-05 12:48:47:064_R:] +QSIMSTAT: 1,1

[2022-11-05 12:48:47:069_R:] DSR:0 CTS:0 (RI:1) DCD:0

[2022-11-05 12:48:47:188_R:] DSR:0 CTS:0 (RI:0) DCD:0

[2022-11-05 12:48:47:338_R:] +CPIN: READY

[2022-11-05 12:48:47:342_R:] DSR:0 CTS:0 (RI:1) DCD:0

[2022-11-05 12:48:47:352_R:] +QUSIM: 1

[2022-11-05 12:48:47:461_R:] DSR:0 CTS:0 (RI:0) DCD:0

[2022-11-05 12:48:47:613_R:] DSR:0 CTS:0 (RI:1) DCD:0

[2022-11-05 12:48:47:619_R:] +QIND: SMS DONE

[2022-11-05 12:48:47:735_R:] DSR:0 CTS:0 (RI:0) DCD:0
[2022-11-05 12:48:56:434_S:] AT+QENG=“servingcell”
[2022-11-05 12:48:56:443_R:] AT+QENG=“servingcell”

[2022-11-05 12:48:56:443_R:] ERROR
[2022-11-05 12:49:12:642_S:] AT+QCFG=“BAND”
[2022-11-05 12:49:12:655_R:] AT+QCFG=“BAND”

[2022-11-05 12:49:12:655_R:] ERROR

[2022-11-05 12:49:17:919_R:] +QCSCON: 1,1

[2022-11-05 12:49:18:915_R:] +QCSCON: 1,0

[2022-11-05 12:49:18:920_R:] DSR:0 CTS:0 (RI:1) DCD:0

[2022-11-05 12:49:19:036_R:] DSR:0 CTS:0 (RI:0) DCD:0
[2022-11-05 12:49:24:973_S:] AT+CEREG?
[2022-11-05 12:49:24:982_R:] AT+CEREG?

[2022-11-05 12:49:24:993_R:] +CEREG: 0,3

[2022-11-05 12:49:24:993_R:] OK
There are ERRORs when I executed AT+QENG=“servingcell” and AT+QCFG=“BAND” commands.
Thank you

This message indicates that RRC connection has been established between the module and the base station. As for the rejection, I personally think it is caused by APN. Please check the APN of your SIM card again, and configure it by AT+CGDCONT, and then test again

Hi, I just bought another SIM card from Telstra. I configure APN by AT+CGDCONT=1. “IP”, “telstra.internet” and then reset the module. Now it is connected. Next I will try to see whether the module can be connected using a Vodafone SIM again. Thank you very much for your help.

I have sent you the latest firmware version, please upgrade and try again

I configured the APN by AT+CGDCONT=1, “IP”, “spe.inetd.vodafone.nbiot” after inserting the Vodafone SIM and resetting the module. Still get no luck with Vodafone SIM. The registration is still denied. Please help! Thank you.

Please upgrade and try again. If it still fails, check the APN

Thanks, I upgraded the firmware, set the APN as
Please refer to Vodafone APN here: APN Settings for Your Device | Vodafone Australia.
Still failed to registration.
For Telstra SIM, it works fine, I can send SMS to my phone.

Does Vodafone Australia have SIM cards for other APNs? Have you tried to debug SIM cards with other APNs?

This indicates the SIM is an ordinary Vodafone SIM rather than an IoT SIM according to BG96 – initial connectivity testing – ANZ Team

The SIM’s home network is Vodafone Australia (50503).

It may be worth trying the AT+QCFG="servicedomain",1 setting recommended on that site.

Thank you. I have followed the suggestions on that site. It just changes from “registration denied” to 'not registered", even after trying that setting. set the APN and reboot the module.

I’ve purchased a new retail Vodafone Australia SIM card to try to duplicate your problem with my BG96.

When activating, I’m asked whether I’ll be using the SIM for voice/SMS/data, or for data only.

If you’re using a “retail pack” SIM, what did you choose as the intended use of the SIM?