QUECTEL EG25 Connection Problem

Hello I am using Quectel EG25 mpcie module. And i am using qmi protocol over it wit hraspberry pi
i am having issue with the sequence of connection with libqmi . as Stated from several documents i am using udhcpc -i wwan0 after using qmicli command.
the issue is after getting ip from udhcpc suddenly the network gets disconnected. it means qmicli -d /dev/cdc-wdm0 --wds-get-packet-service-status output goes to disconnected. First We debug if network is stable so we tried different network provider but same goes for all. after issuing udhcpc command qmi suddenly gets disconnected for all network provider.

1 Like

Hi,
Thanks for your query in forums.

  1. Does your current system have modeManager dialer?
    If so, please disable or uninstall;
  2. Please check whether you only have the dial-up link of WWAN0, and whether there is any occupation problem with other dial-up channels.
    Thanks.

I have already uninstalled modemmanager and added denyinterfaces wwan0 to dhcpcd.conf.

Also i have tested the network strength it is always around -52db.

Same m2m airtel simcard is working fine in android phone and ublox module.
But the behaviour is strange with EG25. It is getting disconnected very often.

Hi,
Can you send AT+QENG=“servingcell” and AT+CEREG?
At command to query the current network information for me to see.
Thanks.

AT+QENG=“servingcell”
+QENG: “servingcell”,“NOCONN”,“LTE”,“TDD”,404,98,C43CA16,265,39150,40,5,5,1FF9,-94,-16,-56,13,-

AT+CGREG?
+CGREG: 0,1

Currently cgreg is 0,1 because it is connected.

Sequence for Connect:

  • ifconfig wwan0 down
  • echo Y > /sys/class/net/wwan0/qmi/raw_ip
  • ifconfig wwan0 up
  • qmicli -d /dev/cdc-wdm0 --dms-set-operating-mode=online
  • qmicli -p -d /dev/cdc-wdm0 --device-open-net=‘net-raw-ip|net-no-qos-header’ --wds-start-network=“autoconnect=no,apn=‘airteliot.com’,ip-type=4” --client-no-release-cid
  • udhcpc -i wwan0

Before applying udhcpc command qmicli reports ip by using this qmicli -d /dev/cdc-wdm0 --wds-get-current-settings command.

Error: but After applying udhcpc command packet service gets disconnected from qmicli. and qmicli -d /dev/cdc-wdm0 --wds-get-current-settings command shows out of call error. and Not able to send request to any server. Sometimes Connection does keep up but after 4-5 seconds it gets out of call.

Sequence for Disconnect:

  • qmi-network /dev/cdc-wdm0 stop
  • killall udhcpc
  • ifconfig wwan0 down

Same sim card is working fine with android phone and ublox module. it is something strange behaviour with EG25. APN is also same. so network stable in the area.

I have logged how many times it reconnects to network and it is quite strange number

Fri 23 Apr 2021 01:18:43 PM IST
Fri 23 Apr 2021 01:19:57 PM IST
Fri 23 Apr 2021 01:21:36 PM IST
Fri 23 Apr 2021 01:23:02 PM IST
Fri 23 Apr 2021 01:55:10 PM IST
Fri 23 Apr 2021 01:56:30 PM IST
Fri 23 Apr 2021 01:57:43 PM IST
Fri 23 Apr 2021 01:59:03 PM IST
Fri 23 Apr 2021 02:00:16 PM IST

Linux kernel : 5.10.27-v7l+ and qmicli version : 1.22.0
udhcpc version : BusyBox v1.30.1 (Raspbian 1:1.30.1-4) multi-call binary.

can you tell me where is QENG command in at command datasheet since i can’t find that command in the datasheet.

Hi,

  1. When WWAN0 goes offline, you say “AT+CFUN”.
    AT+CPIN?
    AT+CGREG?
    AT+QENG= “servingCell”, is it convenient to test
  2. Please send me the screenshots of the corresponding versions of Gobinet/QMI WWAN driver and Quectel-CM tool to check whether they are the latest ones.
    Thanks.

attaching screenshots

Please guide me how can i check wwan driver version. other than that information is below

Note: Sir as i posted earlier i am checking cgreg before applying connect and i am also getting ip. it just gets disconnected after 2-3 s after getting ip. other than that if i don’t apply for ip address than connection stays stable for very long time but as soon as i send a request for dhcp lease it gets disconnected.

I tried to recreate a problem here it is.
root@P1002:/home/oizom# ifconfig wwan0 down
root@P1002:/home/oizom# echo Y > /sys/class/net/wwan0/qmi/raw_ip
root@P1002:/home/oizom# ifconfig wwan0 up
root@P1002:/home/oizom# qmicli -d /dev/cdc-wdm0 --dms-set-operating-mode=online
[/dev/cdc-wdm0] Operating mode set successfully
root@P1002:/home/oizom# qmicli -p -d /dev/cdc-wdm0 --device-open-net=‘net-raw-ip|net-no-qos-header’ --wds-start-network=“autoconnect=no,apn=‘airteliot.com’,ip-type=4” --client-no-release-cid
[/dev/cdc-wdm0] Network started
Packet data handle: ‘2268787488’
[/dev/cdc-wdm0] Client ID not released:
Service: ‘wds’
CID: ‘17’
root@P1002:/home/oizom# qmicli -d /dev/cdc-wdm0 --wds-get-current-settings
[/dev/cdc-wdm0] Current settings retrieved:
IP Family: IPv4
IPv4 address: 10.117.230.194
IPv4 subnet mask: 255.255.255.252
IPv4 gateway address: 10.117.230.193
IPv4 primary DNS: 202.56.215.41
IPv4 secondary DNS: 59.144.144.99
MTU: 1500
Domains: none
root@P1002:/home/oizom# sudo ip link set dev wwan0 up
root@P1002:/home/oizom# sudo ip addr add 10.117.230.194/30 dev wwan0
root@P1002:/home/oizom# sudo ip route add default via 10.117.230.193 dev wwan0
root@P1002:/home/oizom# qmicli -d /dev/cdc-wdm0 --wds-get-current-settings
error: couldn’t get current settings: QMI protocol error (15): ‘OutOfCall’

This is what i am getting error at some times it works some times it doesn’t. I have also tried udhcpc as well. but that will do the same

We are using this antenna if there is any recomennded antenna please suggest

Hi,
1.According to the signal quality of the module network you sent above, I think the reason for the antenna may be small.
2.Can you successfully ping IP directly.
3.Please make sure that the BusyBox UDHCPC tool has not called the Default.script.
The default.script script is called:
image
If the default script is not called, put the default script in the quectel-cm directory under the default call path of the UDHCPC tool. Execute #busybox udhCPC – h to see the default location of the script.
image
Thanks.

Hello Sir,

  1. I have confirmed that twice quectel-CM is not calling default.script it is calling script from inside of the directory.
  2. Yes I am able to ping but after 5-6 second i am not able to ping at all.
  3. Can you suggest better antenna for the EG25. The antenna we are using https://sixfab.com/product/lte-main-diversity-gnss-triple-port-u-fl-antenna-100mm/

If it is antenna problem please suggest a better antenna for EG25 for lte.

Hi,
1.The antenna parameter requirements of our module generally meet the antenna parameter requirements in the hardware manual of the corresponding module.
2.If you need my recommendation, you can choose one from the list of antenna products in our official Quectel flagship store, such as the one in the picture below
(https://yiyuanznsb.tmall.com/)


This is our domestic website, and I am not sure whether you can log in and purchase successfully. If not, please refer to the antenna parameters in the hardware design manual of EG25 to purchase from your existing purchase channel.
Thanks.

what is idle signal network for the eg25

Hi,
Please refer to the EG25 Hardware Design Manual documentation.


Thanks.

I am refering about idle signal strength. what is the required signalstrength since i told earlier i am not getting errors in ublox with same signalstrength and same antenna

Hi,
Sorry, I don’t understand what you mean by idle signal strength. For signal strength and quality, we generally only need to pay attention to RSRP> 105dBm and SinR >10 before normal network injection, thank you.

Hi,
I’m sorry, RSRP > - 105dbm,thanks.

hi,kerr:你的驻网SINR值要求太高了 :joy:

Thank you that is exactly what i wanted to know

Now as i stated earlier can you help me why am i getting out of call too frequently in EG25. The same sim and antenna is working fine with ublox.