MC60 GPS not working


I’m trying to develop GPS app, but have some troubles. MC60 do not response on AT+QGNSSRD?.
Version of firmware is A13.
I tried to reflash firmware, but had an error on gps state.
What can be wrong?

I’m sorry to reply you so late.
Did you excute AT+QGNSSC=1 to power on the GNSS?

make sure your module is in all-in-one solution mode.
please refer below image.
Also execute the AT+QGNSSC=1 to power on the GNSS.

Hello sir,
According to the example provided in SDK for example_gps.c, I compile it and reflash my MC60E module.

As shown in the example, all are callback functions and it should print all debug messages on the main port, but only "-- Ril is initialized "message coming on the serial port and nothing appear after that.

According to the user manual for GNSS engine, i have short J106 and also short GNSS_UART with AUX_UART to get data. but it not working.

According to the user manual D102 led should lit up but it’s not working.

To cross verify I also connect UART3 to PC but nothing appears on the screen.

What could be the problem?

Thank you.

Hi Nayan ,

Are you using EVB or your OWN board ?

We need to make GNSS_VCC supplied to make GNSS ON .

Thank you

I have an EVB kit.
As shown in the pic I have short auxiliary pins and GNSS pins through a 1k resistor, still not working.

Whenever I power the GPS engine send data on the UART3 port, but according to example_gps.c I register UART1 for the reception for GPS data then it should dump data to the main port. But it’s not happening.

What could be the problem?

Hi ,

you need not to short that using Resistor , you just need to put both switch in ON condition .
For GPS to make On with example_gps.c , you need to give one command from main port .

See below , I sent “GPSOpen” and "GPSRead=“ALL” from main port .
Off course you can modify code to make these things automatic .

01-03-2021 18:56:21.912 [RX] -
<-- OpenCPU: GPS Example -->
<-- RIL is ready -->

01-03-2021 18:56:24.759 [TX] - GPSOpen
01-03-2021 18:56:24.792 [RX] - Power on GPS Successful.

01-03-2021 18:56:31.974 [TX] - GPSRead=
01-03-2021 18:56:32.032 [RX] -
+QGNSSRD: $GNRMC,235947.094,V,0.00,0.00,050180,N5C

Hello Sir,
I have an MC60E EVB kit and I’m looking for an OpenCPU example to communicate with AWS.

I already gone through a topic which is raised by a person on this forum the link is

He is using an external MCU to communicate with MC60E chip. I also did same procedure by qcom software and i successfully able to send and recive messages from AWS. and vice versa

Now I am looking for a Example code in OpenCPU SDK to communicate with AWS.

If there any code available to communicate with AWS using MC60E OpenCPU SDK, please do share it with me.

Thank you.