L89 not obtaining fix

Hello. I am writing this post becase I am working with a L89 GNSS module and I am not able to obtain FIX with it. All the tests shown here are with the module outdoors connected to a UART/USB adapter after ~5min with the module on.

This is the serial output of the module:

$GPRMC,154816.000,V,0000.00000,N,00000.00000,E,,,100922,,,N*71
$GPGGA,154816.000,0000.00000,N,00000.00000,E,0,01,99.0,100.00,M,0.0,M,,*62
$GPVTG,,T,,M,,N,,K,N*2C
$GNGSA,A,1,30,,,,,,,,,,,,99.0,99.0,99.0*1D
$GNGSA,A,1,,,,,,,,,,,,,99.0,99.0,99.0*1E
$GNGSA,A,1,,,,,,,,,,,,,99.0,99.0,99.0*1E
$GPGSV,1,1,01,30,00,000,28,,,,,,,,,,,,*41
$GPGLL,0000.00000,N,00000.00000,E,154816.000,V,N*4E
$PSTMANTENNASTATUS,1,0,1,0*51

Serial output after reboot:

$PSTMVER,GNSSLIB_8.4.14.21_ARM*43
$GPTXT,L89NR01A06V01*23
$PSTMVER,OS20LIB_4.3.0_ARM*47
$PSTMVER,GPSAPP_2.8.4_ARM*12
$PSTMVER,BINIMG_4.5.12.4_ARM*37
$PSTMVER,SWCFG_81065329*6C
$PSTMVER,STAGPSLIB_6.0.0_ARM*5A
$PSTMVER,STA8090_622bc043*6F
$GPTXT,(C)2000-2018 ST Microelectronics*29
$GPTXT,L89NR01A06V01*23
$PSTMSWCONFIG,1,0,12,0001050105070a0a0e0d0c0b0a090608070203630a110c04110c0155030130500f00000f0714000affffffffffffffffffffffffffffffffffffffffffffffff*47
$PSTMSWCONFIG,1,1,12,ffffffffffffffffffffffffffffffffffffffffffffffffffff010101000001094005ffffffffff4c9641095600180000000000000000000000000050000000*44
$PSTMSWCONFIG,1,2,12,ffffffff00000000ffffffff000000000000000000000000ffffffff000000000000000000000000fffffffffffffffffffffffffffffffff090c02b05282000*45
$PSTMSWCONFIG,1,3,12,01323200050358020a0a0000fe0300001690813ecd0000bc1000c27e0000000000000000000000000000000000000000000000000000000000000000ac07730d*1D
$PSTMSWCONFIG,1,4,12,120000009a106464ae61840000000100ff0a0b0019000000010101000000000006000000ffffffff040000000100000000000080b004780503000000f0c3f7ff*4F
$PSTMSWCONFIG,1,5,12,00000000ffffffff000000000c0a00020fb4a005f5a30000010a1900330a0a1400510000800e000000001810000008000e01000000000000020f000000000000*42
$PSTMSWCONFIG,1,6,12,0000e803ffffffff00000000ffffffff4810c703ffffffff9abed2e6edf2fafb00000202050601011d11ff000e010f01ff00ff000403ff000000000000000000*4A
$PSTMSWCONFIG,1,7,12,000000000000e03f0000000000000000000000000000f03fd3872ea86f754440938c9c853d8d2c403db83b6bb71b56404b0484b86d3da53e0cb8df888b2f9c3e*49
$PSTMSWCONFIG,1,8,12,2b69a4292b1b503e0cb8df888b2f9c3e4b0484b86d3da53e000000000000000000000000000000005feffe78af8e44406c21c84109c32b400000000000002440*40
$PSTMSWCONFIG,1,9,12,1d8f19a88c8f4440598b4f0130be2b4000000000000024407ac2120f289f44402315c616828c2b400000000000002440ace28dcc239f444095826e2f698c2b40*12
$PSTMSWCONFIG,1,10,12,00000000000024400f0c0c120f0c0c120f0c0c120f0c0c124c38394e523031413036563031000000000000000000000000000000000000000000000000000000*25
$PSTMSWCONFIG,1,11,12,0000000000000000000000000000000000000000000000000000000000000000*26

Teseo-Suite Pro status:

After sending “$PSTMCFGTDATA,1964,3443,10,0000001214" as suggested here I receive "$PSTMCFGTDATAOK18”. Finally, I already tried flashing the latest firmware (R01A06) following this guide. The process went ok but I still get no fix.

This is the schematic of my implementation:

Any help will be welcome.

Hi Teto_Titez,

Here are suggestions for you:

  1. RESET circuit

  1. Your firmware is an old version, if you need the latest firmware, please leave a comment.

  2. Testing device: Please test the module locating performance in an open sky environment.

Best regards.

Thank you for your reply.

  1. As stated in the datasheet, the RESET pin can be left unconnected. The module is not resetting itself, so this it not a problem.

  2. I would appreciate if you could send me a download link to the latest firmware.

  3. As already stated, all tests were performed outdoors (open sky).

Hi Teto_Titez,

The latest L89 firmware is sent to your message.

Best regards.

Hi, can i get the latest firmware for L89.
Also will the gps will get fix if the Vbackup is open.
All my L89 did not give out any output when the Vbackup is open.

Hello again.

I updated the firmware, but the issue persists. The UART output remains the same (see first post), and there is no FIX. I would really want to solve this problem since we are thinking about implementing this GPS module in our new product but due to it we cannot to beyond the prototyping stage.

Regards.

Hi Binu_Johnson,

V_BCKP pin needs a voltage and can not be open, you can power the V_BCKP pin with VCC.

If you need a backup mode, please ensure a durable power supply to V_BCKP pin.


Hi Teto_Titez,

Could you please try to supply power to the module alone? This method aims to check the module can get a location or not.

L89 hardware design is sent via message, wish it would help.

Best regards.

Dear Raphael.

I have both updated the firmware to the version you sent me and revised the Hardware guide. This is the only output I obtain from the GPS module when connecting it to a UART/USB adapter:

$GPRMC,001258.000,V,0000.00000,N,00000.00000,E,,,200922,,,N*73 
$GPGGA,001258.000,0000.00000,N,00000.00000,E,0,02,99.0,100.00,M,0.0,M,,*60 
$GPVTG,,T,,M,,N,,K,N*2C 
$GNGSA,A,1,22,26,,,,,,,,,,,99.0,99.0,99.0*1A 
$GNGSA,A,1,,,,,,,,,,,,,99.0,99.0,99.0*1E 
$GNGSA,A,1,,,,,,,,,,,,,99.0,99.0,99.0*1E 
$GPGSV,1,1,02,22,00,000,26,26,00,000,29,,,,,,,,*70 
$GPGLL,0000.00000,N,00000.00000,E,001258.000,V,N*4F 
$PSTMANTENNASTATUS,1,0,1,0*51