L89 firmware, NMEA 4.10, BeiDou and L5 band

I’m looking the L89 modules with the embedded patch antenna and chip antenna.

What is the latest firmware version and where can I download it from? I get this for the version information:


How do I enable NMEA 4.10 sentences? Via firmware update or commands? If firmware, where is the location to download both the 3.01 NMEA and 4.10 NMEA modes? If commands, how do I switch back and forth?

The modules never reports any BeiDou data. I’ve set bit 7 of $PSTMSETCONSTMASK. How do I enable BeiDou data?

I’m not sure if I’m seeing L5 band data. Perhaps enabling NMEA 4.10 will show it in the $–GSV sentence? If not, how do I see the band carrier frequency?

Actually, given enough time I do see 5 BeiDou satellites here in the eastern USA. So, that is not a problem.

Dear RJFlatley,
1, Switch to NMEA 4.10:
$PSTMSETPAR,1122,0X04 //Switch to NMEA 4.10
$PSTMSAVEPAR //Save parameters
$PSTMSRR //Restart

2, Switch to NMEA 3.01(default):
$PSTMSETPAR,1122,0X0C //Switch to NMEA 3.01
$PSTMSAVEPAR //Save parameters
$PSTMSRR //Restart

3,L5 band:
L89 only supports IRNSS L5 band.


Thanks BR for the instructions on how to enable NMEA 4.10.
I take it there are no firmware updates at this time?

It’s disappointing to learn the module does not support the L5 band for GPS and Galileo. The L89 spec sheet is misleading at best.
“With two embedded antennas, the module can work at L1 and L5 bands simultaneously.
Compared with the GNSS module working at L1 band only, L89 can make use of GPS, Galileo and IRNSS signals to increase the number of visible satellites, reduce TTFF and enhance positioning accuracy, especially when it is used in rough urban environments.”

How does the L89 “enhance position accuracy” and other claims when compared to GNSS with L1 only outside of the IRNSS coverage area? Will there possibly be a future firmware update to enable the L5 band for GPS/Galileo?

Dear Sir,
1, You could check your FW version like L89XXXX when power on module. Also I added the most recent firmware and the upgrade tool in the link as below: please refer to EVB user guide to upgrade.
Firmware: L89NR01A06

Flash tool: STA808x-9x Firmware Upgrade

2,Sorry for the possible misleading caused by the document. Since IRNSS mainly uses L5 band, L89 embeds a specific internal chip-set to support. Due to hardware limitations, L89 won’t be able to support L5 band for GPS/Galileo.

Best Regards

Hello Berton.Peng,

Power up reports $GPTXT,L89NR01A04V02*22

To upgrade to R01A06, could you kindly provide more details on what tool or tools to use and what bin files to use? Your downloads have two tools. FlashTool_exe_v4.1.0 and STA808x-9x Firmware Upgrade.exe and two bin files. L89NR01A06_BOOT26.bin and L89NR01A06_UPG26.bin. What tool do I use and what bin file? Or do both bin files get loaded at different addresses?

I have the L89 connected to a Windows PC at 115200 baud with an FTDI USB to Serial adapter.


Dear Sir,
The flash tool is STA808x-9x Firmware Upgrade.exe.
The bin file is L89NR01A06_UPG26.bin. You could refer to the L89 EVB user guide.

Best Regards

Thanks. I used the STA808x-9x Firmware Upgrade.exe tool. The first time I tried to use the tool. I had both the Erase NVM and Recover boxes checked. The tool stuck “Synchronizing with target device”. So, I tried again with no boxes checked. This time the UPG bin file successfully loaded. However, the L89 now seems dead. Does not output anything on power up (at both 9600 baud and 115200). It no longer responds to NMEA commands. I thought I’d try the X-Loader tool within Teseo but that tool is not enabled by default (need product key to unlock). Suggestions?

Dear Sir,
When the tool stuck “Synchronizing with target device”, L89 reset is needed to continue.


Hello @Berton.Peng-Q
When the tool stuck,I’m resetting the L89 module,but did not work.Please give any suggestions.

Thanks in advance!

Dear Sana_Shaikh,
Did you tick Recovery?
Please refer to below screenshot, thank you.


Best Regards

Hello @Berton.Peng-Q
Yes.I tick the both check boxes Erase NVM & Recovery,but still it is not upgrading,& tool stuck.Please do the needful.
Thank you!

Please check it.I tick both check boxes.

Dear Sana_Shaikh,
Please select as below screenshot.


If it still cannot work, you could update in boot mode with TeseoIII XLoader_v2_2.exe in the link below. Please refer to Quectel_L89_EVB_User_Guide_V1.0. Thanks.

Best Regards

Yes.I selected all options as per given screenshot.But stiil it is not working,tool stuck up! And from link ,I ran the Teseolll XLoadre_v2_2.exe.I refer L89 EVB user guide,but on my EVB board there is no DL button.


Hello @Berton.Peng-Q
Any other solution ,how to upgrade firmware Of L89.?I require urgently .

Thank you in advance!

Dear Sana_Shaikh,
Did you select 115200bps in NMEA baud rate and Baud rate?
Also, please double check if you could send command to your L89 module successfully, e.g: $PSTMGETPAR,1500.

Best Regards

I will try & let you know.

I selected both NMEA & baud rate as 115200,but issue not resolved.
And I sent $PSTMGETPAR,1500 this command successfully, it results as $PSTMSETPAR,1500,L89NR01A04V02*5E

Hi Sana_Shaikh,
Could you email your sch diagram to me?
Email address: berton.peng@quectel.com
Best Regards