L76-LB: Can't update firmware


We have acquired an L76-LB GNSS module to use in our project. And, in order to get it working over i²C, we need to update the module with the firmware L76LBNR03A02SC, since the modules did not come with the proper firmware version.

But the problem arises with the FlashTool application, where althought i’ve followed the proper instructions included in the FlashTool folder, it generates the following error at the firmware download:

I’ve tried using different USB to UART modules, matching the voltages that use the GNSS module (2.8V), using other computers, running the tool with admin privileges and applying different baud rates (after setting the proper baud rate on the GNSS module, of course) but the error still shows up. However, the UART communication is OK; I got the NMEA payload and I can send and receive PMTK coomands through UART. But we need to interface the module through I²C.

How can I solve the upgrading issue? It should be noted that I’m using the firmware and FlashTool published in the following thread:

Dear Sir

  1. Please check whether the serial port of L76-LB is occupied?
  2. Please make sure that the COM port selected in “Settings” in FlashTools is correct?

Hi Albert,

I’ve also checked that the serial port is not occupied by any other process and the COM port is properly selected by checking it in Device Manager, but the problem still occurs.

Dear Sir

  1. Is the serial port of L76-LB connected to MCU?
  2. Or you can try another computer?

Hi Albert,

The serial port of the L76-LB is not connected to the MCU. The UART ports were left unconnected to any device in the project for debug and firmware update purposes. Also, I’ve tried to load the firmware using different computers (all of them with Windows 10), but it keeps showing the same error.

Can we make an appointment? Then I use remote tools to upgrade you remotely.

Of course. Can I send you a PM in order to agree the date and time of the appointment?

I’m here in the Beijing time zone.which time zone are you in?
We can make an appointment in the morning or afternoon.
What remote tool do we use remotely? Is TeamViewer possible?

We’re in Bogotá time zone (UTC-05:00). Since our time zones are too disparate between them, we should make the appointment at morning (in Beijing). Could be possible to schedule at 08:00 (UTC+08:00)? For sure, we can use TeamViewer.