IPPT and DNS on RM520N-GL

Hello mates

I have successfully enabled IPPT on RM520N-GL and getting my Public IP on my home router, but still the DNS is showing the GW IP which is
I tried “dhcpv6dns” to set enable, but still I can’t receive ISP’s DNS. BTW im using IPv4 and Im somehow sure the above option will not work.
Anybody knows how to get the DNS in IPPT from ISP?
Thanks a lot


First of all check what address(es) do you have with at+cgpaddr and what else was received from the carrier with AT+CGCONTRDP=1 (assuming context 1 is in use).

My understanding that both dhcpv4dns and dhcpv6dns should be disabled, as these settings are for DNS proxy, if I’m not mistaken.

Hello, can you share which commands you applied to successfully enable IPPT on RM520N-GL, as I have tried many commands but (even though I issued the command to disable NAT and the DHCP server) I still get the NAT ip DHCP address…


Use below in sequence


Remember MAC address is the same of your home router WAN MAC and you must have Public IP else you will see the CGNAT ip of ISP

I didn’t see dhcpv4dns in commands manual. Will check twice

Thank you. I tried many commands, including the ones you listed, but not necessarily in the order you say!

I assume you mean the actual letters - XX:XX:XX:XX:XX:XX (and not X=“some number” as in x, y and z in maths?)

Also, is your RM520N-GL flashed with (what I think is) the latest firmware - RM520NGLAAR01A07M4G_01.203.01.203


XX:XX:XX:XX:XX:XX represents your router WAN MAC

1 Like

I have 200 version. I received A08 from Silvia and going to flash it but still waiting for the AT commands associated with this version. Still not confident as this is my first time to update the firmware. Not sure which file should I choose. I know it’s .elf but not sure which one. And yes the XX is max address real number like 90:09…….

BTW did you at+cfun=1,1? Have you reset your modem after commands?

I believe I did reset my modem but can’t remember.
I will try the commands later, thanks!

Hello, I can’t get anywhere…
I’ve tried your commands, used the MAC of the router’s interface but I still get the NAT IP address (even though NAT is supposed to be off, at the module -

In fact, the command with the MAC address isn’t accepted by the modem -


The only form of this command that is accepted is with all FF for the MAC, ie


Very puzzling.

OK, I have succeeded in changing the ipptmac address (using quotes “” didn’t work).

To change ippt mac you need to OMIT quotes:


But haven’t got MPDN_rule to work yet…

If anyone has a newer version of the AT commands document for the latest firmware specifically for the RM520N-GL, I’d greatly appreciate it if anyone could email or message it to me. Thanks!

Bro I understand the issue
Are you on ?

if yes, then you must use all lower case in AT commands. I updated from RM520NGLAAR01A07M4G_01.200.01.200 to RM520NGLAAR01A08M4G_01.200.01.200 and I faced the same issue you had. So i used all “lower case” when I was entering any command, even “mpdn_rule” in lower case and I could get the IPPT works. I also disabled “dhcpv4dns” to get the ISP DNS.

Should add that after update, all my IPTT config erased and I needed to do that again. So @jfrog was right that sometimes your config will be lost :slight_smile:

Hope this helps, also please send me your latest AT commands file.


1 Like

Here is the version I have…
Quectel_RG520N&RG525F&RG5x0F&RM5x0N_Series_AT_Commands_Manual_V1.0.0_Preliminary_20230731.pdf (2.1 MB)


I’m actually on the earlier version - RM520NGLAAR01A07M4G_01.203.01.203


If you want I can send you my version and you can test. I successfully activated IPPT on it

Thanks, that would be great. Much appreciated!

CAUTION: After update all your current IPPT settings will be discarded.


XX:XX:XX:XX:XX:XX MAC address of your home router WAN (All small case)


Will try this later!

Oh, I think the first command is to disable rgmii, and then you re-enable it?
I think i found that it only accepted the MAC if you had immediately disabled rgmii before (at work, from memory).

These modules are essentially a router with the size of a postage stamp but are rather complex to use!

Yeah this was how I understood the rgmii functionality, in case you succeed to activate the IPPT, then mark post as solution :wink:

1 Like