Info FC41D in BLE peripheral mode

we are working with FC41D BLE/WiFi module. Our need is to make it works as BLE peripheral device.
In particular we need to make it works as BLE/Serial bridge. The data send through from a device BLE should be send to Main serial of FC41D and viceversa.
We found some information on the forum and also on “FC41D AT Commands Manual v1.0-1” about the configuration and use of the board through AT commands.
We didn’t find any answer to the following points:

  • how to set an uuid 16byte(custom), i.e. AT+QBLEGATTSCHAR=00000001000010008000008025000000 not work but the answer of the command is OK
  • the name of the board is not readble form the standard charcteritstic 0x2A00 related to service 0x1800, also after AT+QBLENAME command
  • Is there a way to switch to BLE/serial terminal bridge ? For the moment we receive packets from BLE devices but we can’t answer to them. The only way to send something is i.e. “AT+QBLEGATTSNTFY=fff3,packet" that send on service fff3 the notification message “packet”.
  • Is there a way to change characteristics proprieties ? By defaul they are NOTIFY e WRITE.

Thanks in advance for any reply,


Please check below image for BLE_name and customized UUID , which can be set and is working
Check the firmware version you are using at your end , you might be using some old firmware +QVERSION:FC41DAAR03A05.bin_202209091118

There are to ways to send data from device

Characteristic properties change will be implemented in new release , which is expected in one-two weeks, currently change of properties is not supported.


Thanks for the quick reply! I’m using this firmware FC41D_VERSION:FC41DAAR03A03.bin_202203110937
I’ll try to upgrade the board.
Thanks a lot for your help.
So the board can’t work as serial/BLE bridge ? The only way to send data from serial to Ble is to use the following commands ?
Sorry if I ask again but I experienced with boards that after AT commands switch to terminal IO mode and start to be a simple bridge board.

Thanks again,

hi UF
there’s one more way , that is send data in transparent mode

BLE test.pdf (439.6 KB)

Please check if it fullfills the requiment , I will share you the rewuired firmware and tool.


The trasparent mode could be the right way. Thanks!
It is necessary a particolar firmware to use FC41d in that mode ?
Sorry if I ask another thing: I tried also to update FC41D to lastest firmware as you seggested me. I always received error code 4, and flash fails.
Screen below

I can’t find an error list for QFLASH, so I don’t know what is the issue. Do you have any idea? Maybe I have have a too old version and should upgrade to a newer one before the lastest ?

Please set baud rate to “921600”

thanks again for the quick reply. Unfurtunately with baud rate 921600 the result is error code 18 and the QFLASH don’t finish the erasing procedure.

do you press reset button when Qflash states "Erasing Flash "

I tried conneting CEN pint to ground for a second during “Erasing Flash” as I’m not working with the evaluation board. It should restart the board as reset button. I have one evaluation board if needed but I need also to update the one that I’m using.
Just to clarify I’m using QFlash version 6.5.

can you please check flashing with Qflash 6.4 , If still doesn’t work please try with BKWriter.

sorry for the late but I’m working also on other projects.
I didn’t find the QFlash v6.4 online, nor bkwriter for Windows.
Can you share them ?

can you please share your email id ?

thanks a lot but in the meanwhile I tried some times with different approach and finally I flashed the FC41D to lastest version. The point was I had to keep reset pressed(CEN pin to ground in my case) during all the startup until the flash program displays “Erasing Flash”. In this way it worked.

Thanks a lot for your help, now I will try the new version and transparent mode as you suggested.


that’s great , you can post here anytime if you face any issue

thanks, very nice.
I tried all the procedure you shared in “BLE test.pdf”.
Commands AT+QBLECFGMTU=512 and AT+QBLETRANMODE=fff2 don’t work.
In particular as I wrote in previous messages I am interested to try the transparent mode.
My board version is FC41DAAR03A06.bin_202302071736. Does it support that commands ?

Please use FC41DAARo3A07.bin
share your email address , I will share the firmware with you in case you don’t have it

Hi thanks,
sent by chat

firmware shared on email.

Thanks for your help Waleed_zafar1!
I tried the transparent mode and it seems to work. Sorry if I answered only now but I was busy.
Unfurtunately I cannot flash the firmware you sent to me but I tried with another firmware from a colleague and it worked.
Only a question: when transparent mode is active I cannot reset the board because every command, also QRST is forwarded and ignored. Is there a way to disable the transparent mode or a way to reset the board via command in transparent mode ?
I prefer to avoid the CEN pin utilization bacause it is and hardware way.

Many thanks again,


you can enter “+++” to exit transparent mode