I need help with my ec21a modem pool none of the drivers are working

I have the Quectel ec21a Modem Pool and despite having the Quectel LTE&5G Windows USB driver package installed, nothing changes in the Device manager for Windows 10 64 bit.

Further, I am using a software called SMS Deliverer instead of SMS caster.
It reads the ports but says the SIMs are unregistered. Except I can put any of them into my phone or tablet and they work fine. The Sims are registered and activated.

Am I missing drivers? Am I supposed to do something specific in a particular order with the following files:


Thank you ahead for any help you can provide. Thank you for your time too.

I need to get this working or I am out of a job.

Did you mean AT+CPIN? Return error code 10 or SIM Card Not inserted.
If so it seems hardware problem.

AT+CPIN gives me:


AT+CPIN? to check wheter the sim card is valid.

But from the log,seems the sim card is valid, and why you said it is not inserted.

E21A Modem pool
5 Sims. All activated. All inserted. Can take them out and use them in a phone or tablet successfully.

The application, SMS Deliverer is telling me the Sims are not activated. Similar to the software, SMS caster.

I want to make sure the Sims are recognized.

Plus,when starting QNavigator, it states that the red lights should be solid. But they flash in a pattern.
For example, slots1,3,and 4 will flash at the same time.
Then 5 will flash, then 2.
Might mean nothing. If i rotate sims and slots, a different flashing pattern.
Electric outlet is good. Power to GSM is good.

AT+QSIMDET, sim card detection shows error in log

AT+QINISTAT, query status of SIM card Initialization

Returns “7”, the sum of the 1+2+4, CPIN ready and SMS Done & PHP done

Thank you for your help sofar.
Still looking for the solution.


SIM card is already recognized.

Thank you.

I should state that I used the wrong word when describing the sim’s status.
They read unregistered.

Would that have anything to do with the network?

It is best to leave only the module that cannot work well, and use AT commands to check,


This screenshot shows the AT Commands you suggested:

What is your conclusion?
Have any suggestions?

Yes. From the AT log, it is not registerred.

Registration denied.

Only that specified sim card cannot work?

I currently have 5 Sims in the slots.
All activated.
But continue to show unregistered

How can I change that?
How can i get them registered?

Which AT Commands will register them?

It appears like I’m not on a network?

Is there an order of AT commands that fix this?

Unfortunately, I made a mistake thinking that as long as I activated them, they could be used.

If the network is rejected, it may be that the card is in arrears, or there is a machine-card binding.
You can check It with the operator.
If you need to move from afar, you need to provide modem log.

How do i access and provide the modem log?

Thank you for your assistance so far.

Here’s an update:

I have tried 3 different types of activated SIM cards in the EC21-A GSM modem pool including the Verizon one in my Samsung Note20 Ultra.

I have tried the different slots in the GSM.
Still same results.

The software still reads “GSM unregistered”.
The QNavigator still gives me registration denied.

I have forwarded the IMEI number and picture of the Quectel chip inside of the GSM EC21-A to a FAE Assistant in Quectel to make sure i can use this GSM EC21-A in the USA.

Maybe there is a setup procedure I’m unaware of?