How to dial-up Internet access for Quectel RM502Q-AE


I have a quectel 5G module RM502Q-AE and the purpose is to obtain position with a GPS antenna

I fellowed this tutorial : RM500Q-GL 5G HAT - Waveshare Wiki

And in the part of “step dial-up intenet access”, i did the AT command, but they didn’t work

I had error for these two.

So i wasn’t able to obtain the position, so i don’t know what to do.

Thanks for your help.

AT+QNETDEVCTL won’t work for RM502Q.
For RM502Q you can follow the

Quectel_RG50xQ&RM5xxQ_Series_AT+QCRMTOOL_Data_Call_Application_Note_V1.0.pdf (306.7 KB)

or use the quectel-CM to setup dacall.


Thanks for your answer, i will try it.

I have another problem if you can help me.
It concerns the GPS Positioning with the same Quectel module

I turn on the GPS : AT+QGPS=1 , it’s OK
But when i try to obtain the position with AT+QGPSLOC=0 , i have error 516 and i don’t know how to solve this issues, i tried the GPS antenna indoor and outdoor and always the same error

Thanks for your answer

Can you get the position through the nmea log?

If you set hte AT+QGPS=1 , the nmea log would output from the nmea port.

516 means “Not fixed now”.
It takes some time for the module get the location.

Yes, after enabling the GPS, i open the NMEA port, i have the NMEA frame but without information of Latitude, Longitude… etc
Like in the picture below. (And i have the same thing when i use linux).

Maybe it has something to do with the antenna.
The GPS gntenna is different from the LTE/WIFI/BT antenna, and it should be placed outdoor.

From the nmea log, the GPGGA didn’t tell us the position fix data , there is no enough active satelites from the GPGSA.


So how can i fix this and obtain the position please?

Could you show how the antenna is placed?

This is the antenna, i put it like this outdoor

(Ps: i also tried to put it in the other face and same thing)

How it connect with the RM502Q-AE?

btw,the antenna should put outdoor.

Hello, yes i put it outdoor and in a tuto from waveshare, i saw that i have to connect the GPS antenna to the interface of ANT3 of the module

Like shown in this picture

Yes. the GNSS antenna should connect with the ANT3_GNSSL1.


Yes, so the GNSS antenna port i used is the right one.

Then what am i doing wrong? Why it doesn’t work?

Again thanks a lot for your answers.

RM502Q-AE only support Passive Antenna.
Could you check whether it is passive antenna or active antenna.

Yes, it’s a passive antenna


I get this know, what do you think?


Please wait for several seconds. It might work and return the location for the GPGGA.