Firmware request for RM500U-CN

Can I please get the latest stable firmware and flashing tool for RM500U-CN?

Hello there, would really appreciate to get some support on this modem i own too.

are there any firmware upgrades available?

Kind regards

were you able to get this connected to the internet?

followed also your other thread…
tried to connect via router (openwrt/rooter firmware) in an m.2 to usb adapter (dual q mh2u) in ecm mode
after changed settings according your other thread (ethernet, nat), modem gets ip adress but no traffic… also support by router firmware forum has no solution yet

I got this from waveshare support.

There are three firmwares here, I tried flashing with all three. No results.

thx a lot, seems some mbim support is added with the upgrade, maybe that helps me with my router
Will try asap

so even with a19 firmware no success

What is your output for at+cgpaddr and at+cgdcont?

+CGPADDR: 1,“0000:0000:0000:0000:0001:0000:b65a:299f”
+CGPADDR: 2,“”,“2a01:059f:b916:a294:0001:0001:7b65:1eee”
+CGPADDR: 11,“”,“0000:0000:0000:0000:0001:0001:7b65:1734”


+CGDCONT: 1,“IPV4V6”,“internet.v6.telekom”,“”,0,0,0,0,0,0,0,0,0,0
+CGDCONT: 2,“IPV4V6”,“ims”,“”,0,0,0,0,0,0,0,0,0,0
+CGDCONT: 11,“IPV4V6”,“IMS”,“”,0,0,0,0,0,0,0,0,0,0


only change after firmware upgrade, it gives an ipv6 lease…

Try switching the first apn to only IPV6


Then run the two commands again.

cant configure the apn, result: cme error 4 operation not supported??!

That shouldn’t happen. I’ll keep you posted.

Ps: apparently the at+cgaddr command is not very reliable.

send at+cfun=0 (or 4) before and at+cfun=1 after
make sure you use correct parentheses, so don’t copy/paste but type " manually

Hello, I know that this is off topic but could anyone who owns RM500U-CN check their module if it support mbim mode using this AT command.


For me the mode 2 is missing which the doc said it was for mbim

+QCFG: "usbnet",(1,3,5) # <-- Here, 2 is missing

I’ve created a new thread but got 0 response so far.

Thank you in advance.

thx normally i dont copy paste, but with the correct parentheses, the command worked, but still no connection

will try the next few days, unfortunately to less time…

Nope, it’s the same. MBIM is not supported

1 Like

Can you try running at+qnetdevctl=1,1,1 followed by the DHCP client.

will try asap, what dhcp client?

These three with the proper interface,

If the internet starts working try the following commands in sequence, wait for the modem to boot up and then run the dhcp client again and check if it is still working.