Firmware for RM502Q-AE

you might want to try R11A02

I just test R11A04 and R13A02, they both gave me worse signals and I end up not able to connect to any 5G bands unless I have my modem right up against the window facing the cell tower. Even then the speed is 30-40% less than R11A02.

Once I revert back to R11A02, all is well again and was able to keep the modem at a location I wanted. I will probably go back to R13A02 once I get some yagi antennas and try again.

BTW this is my experience with Tmobile in south Florida USA

Hi mrgodai, I am unable to get to that link. I could get to the other quectel links but not that one.
can you repost for us?

I fix the link to the thread it was posted it

I downloaded and tested the R11A02 image and I can now see Band n71 and even ping but I cannot run a speed test or connect to the Internet.

Ping statistics for
Packets: Sent = 4429, Received = 2891, Lost = 1538 (34% loss),
Approximate round trip times in milli-seconds:
Minimum = 16ms, Maximum = 182ms, Average = 33ms

Any thoughts on next steps to make this work? Atleast I see 5G band n71 again.

Anyone have a link to RM502QAEAAR11A03M4G version I can try?
Guessing version 12 was skipped and they went to v13?

It looks like you might have a signal issue.

What router are you using for the modem? Are you sure all 4 antennas are properly connected to the modem and no damages to the connectors? Can you move the modem to somewhere you sure you have a great signal with another device and see if there are any improvements? Is there another router you can try?

Are you using a quality power adapter with at least 2amp? I got a signal improvements with my wg1608 when I switched to a monitor 3amp power adapter than the crappy 2amp it came with.

Normally I would agree but why does v11A02 at least show band n71 but not v11A04 or v13?
Also why does the EM9191 not only connect to the band n71 but allow to get 50-70 mbps download.
The Quectel wont even connect to 5G. Works on 4G LTE all day long.

Also I am getting 20ms pings to Normally if my signal was weak it would not be that low.
When I had the EM9191 connected to same antenna, same fixed point i had a -75db gain signal which is about as strong as you can get not being within a few miles of the Tower.

I am using Bolton Long Ranger Antennas in 2x2 MIMO pointed at my tower from my roof.
I am using an NESX2GO router + USB3 enclosure for the 5G modem with a 4amp power supply.

Only two antennas then?

Which two RM502Q antenna connectors are they connected to (ANT0 through ANT3)?

I think 11A02 allows for a higher power draw that gets higher signal strength because I noticed the temp for 11A04 and 13 are lower than 11A02

Also maybe modem driver on the router is having issue with RM502q. Have you tried newer or older firmware on your router that people have confirmed working with n71 on tmobile?

not even sure there was an R11A03,Rm is different, they make minor fixes, i have seen R11A02 and R11A04.
Tho, there are different versions of R11A02 and R11A04.
Take a look in my folder and see if any of them works.
RM502Q-AE Firmware

what do you get with AT+QRSRP?

How many of the four modem antenna ports have antennas connected? I can’t tell from your reply.

I am using (2) ports in 2x2 but it made no difference. The other 2 are disabled with this command.
AT+QNWCFG= “dis_4mimo_enable”,0

+QNWPREFCFG: “mode_pref”,LTE:NR5G

+QENG: “servingcell”,“NOCONN”,“NR5G-SA”,“FDD”, 310,260,8371C002,310,7C1B00,126290,71,3,-102,-11,17,1919

+QRSRP: -100,-134,-44,-44,NR5G

From the shell prompt:
/usr/lib/rooter/common/ 1 /dev/ttyUSB2; cat /tmp/signal1.file
RSCP=“-101 dBm
ECIO1=" "
RSCP1=“RxD -44”
LBAND=“n71 (Bandwidth 20 MHz)”
SINR=“14 dB”

I am a noob to 5G.

When I set the modem to either of these commands isnt it supposed to only enable NR5G (NA) not (SA)?
AT+QNWPREFCFG= “mode_pref”,NR5G

This is the other command that I can run but it disables both (NA/SA) modes.
AT+QNWPREFCFG=“nr5g_disable_mode”,1 --disables all 5G modes on modem (NA/SA)

It appears to me the modem is by default designed to connect on 5G (SA) mode not (NA) mode like the RM500 modem but I dont see a way to disable just (SA) mode to get NR5G (NA) mode to only connect.

-134 signal on ANT1 is basically not usable. you really want to get to greater than -110 for tmobile 5G to stick.

according to

ANT0 supports 1400-5000Mhz and ANT1 and ANT2 supports 600-6000/5000Mhz. n71 is 600Mhz so that might be your issue since ANT1 signal is really low. You might want to adjust your antenna to get a better signal for ANT1 and enable the other ports to use ANT1&2 instead of ANT0&1 since 600Mhz is only on those and another user reported they are able to run 2x2 only ANT1 and ANT2

Also AT+QNWPREFCFG=“nr5g_disable_mode”,1 disables only SA, but you lose all 5G because you are not able to connect to NSA due to possibly signal issue. It’s better to leave all the setting to auto or default unless you need band locking.

Which two? This is important, and you didn’t answer the question when asked earlier.

I wouldn’t bother with that command. I don’t use it when running with only two of four antennas.

Which two are in use affects which bands are in use.

You are running on a single antenna only.

After Downgrade from A1104 to A1102,its not detected by windows 10 .no com port is showing.please guide how to resolve.

I received a 4x4 MIMO antenna today and did some testing and was able to connect to Band n71 on 5G cellular.
In my testing however I wanted to make sure all 4 antennas were active and ran this command but with the same results. I ran the commands under load as well.

AT+QNWCFG=“dis_4mimo_enable”,0 or ,1 (I believe 1 turns 4x4 On and 0 turns it Off)

I have the 4x4 MIMO connected but seeing the same whether 4x4 MIMO is enabled or disabled:

Disabled = +QRSRP: -119,-104,-32768,-32768,NR5G
Enabled = +QRSRP: -113,-106,-32768,-32768,NR5G

I am assuming the -32768 reading should be reading -100 or so like the other correct?

Is that the correct command to enable the 4x4 MIMO antennas or is there another one I should be using.
This one does not seem to work.

are you still on 11A02?

In RM502QAEAAR11A04M4G_01.002.01.002 there is this note

Modified the default value of AT+QNWCFG=“dis_4MIMO_enable” to 1, and
solved the problem that the configuration might not take effect

you might want to update to see if it fixes the issue

Hello. I would like to get the latest firmware for the RM502Q-GL module. Here is a screenshot of the AT+QGMR command. Thanks!