Firmware for RM502Q-AE

not even sure there was an R11A03,Rm is different, they make minor fixes, i have seen R11A02 and R11A04.
Tho, there are different versions of R11A02 and R11A04.
Take a look in my folder and see if any of them works.
RM502Q-AE Firmware

what do you get with AT+QRSRP?

How many of the four modem antenna ports have antennas connected? I can’t tell from your reply.

I am using (2) ports in 2x2 but it made no difference. The other 2 are disabled with this command.
AT+QNWCFG= “dis_4mimo_enable”,0

AT+QNWPREFCFG=“mode_pref”
+QNWPREFCFG: “mode_pref”,LTE:NR5G

AT+QENG=“servingcell”
+QENG: “servingcell”,“NOCONN”,“NR5G-SA”,“FDD”, 310,260,8371C002,310,7C1B00,126290,71,3,-102,-11,17,1919
OK

AT+QRSRP
+QRSRP: -100,-134,-44,-44,NR5G
OK

From the shell prompt:
/usr/lib/rooter/common/quecteldata.sh 1 /dev/ttyUSB2; cat /tmp/signal1.file
CSQ=“-”
CSQ_PER=“44%”
CSQ_RSSI=“-”
ECIO=“-12”
RSCP=“-101 dBm
-44”
ECIO1=" "
RSCP1=“RxD -44”
MODE=“NR5G-SA “FDD””
MODTYPE=“6”
NETMODE=“8”
CHANNEL=“126290”
LBAND=“n71 (Bandwidth 20 MHz)”
PCI=“310”
TEMP=“36°C”
SINR=“14 dB”

I am a noob to 5G.

When I set the modem to either of these commands isnt it supposed to only enable NR5G (NA) not (SA)?
AT+QNWPREFCFG= “mode_pref”,NR5G
AT+QNWPREFCFG= “mode_pref”,LTE:NR5G

This is the other command that I can run but it disables both (NA/SA) modes.
AT+QNWPREFCFG=“nr5g_disable_mode”,1 --disables all 5G modes on modem (NA/SA)

It appears to me the modem is by default designed to connect on 5G (SA) mode not (NA) mode like the RM500 modem but I dont see a way to disable just (SA) mode to get NR5G (NA) mode to only connect.

-134 signal on ANT1 is basically not usable. you really want to get to greater than -110 for tmobile 5G to stick.

according to https://www.quectel.com/wp-content/uploads/2021/04/Quectel_RM500Q-AERM502Q-AE_Hardware_Design_V1.0.pdf

ANT0 supports 1400-5000Mhz and ANT1 and ANT2 supports 600-6000/5000Mhz. n71 is 600Mhz so that might be your issue since ANT1 signal is really low. You might want to adjust your antenna to get a better signal for ANT1 and enable the other ports to use ANT1&2 instead of ANT0&1 since 600Mhz is only on those and another user reported they are able to run 2x2 only ANT1 and ANT2

Also AT+QNWPREFCFG=“nr5g_disable_mode”,1 disables only SA, but you lose all 5G because you are not able to connect to NSA due to possibly signal issue. It’s better to leave all the setting to auto or default unless you need band locking.

Which two? This is important, and you didn’t answer the question when asked earlier.

I wouldn’t bother with that command. I don’t use it when running with only two of four antennas.

Which two are in use affects which bands are in use.

You are running on a single antenna only.

After Downgrade from A1104 to A1102,its not detected by windows 10 .no com port is showing.please guide how to resolve.

I received a 4x4 MIMO antenna today and did some testing and was able to connect to Band n71 on 5G cellular.
In my testing however I wanted to make sure all 4 antennas were active and ran this command but with the same results. I ran the commands under load as well.

AT+QNWCFG=“dis_4mimo_enable”,0 or ,1 (I believe 1 turns 4x4 On and 0 turns it Off)

I have the 4x4 MIMO connected but seeing the same whether 4x4 MIMO is enabled or disabled:

Disabled = +QRSRP: -119,-104,-32768,-32768,NR5G
Enabled = +QRSRP: -113,-106,-32768,-32768,NR5G

I am assuming the -32768 reading should be reading -100 or so like the other correct?

Is that the correct command to enable the 4x4 MIMO antennas or is there another one I should be using.
This one does not seem to work.

are you still on 11A02?

In RM502QAEAAR11A04M4G_01.002.01.002 there is this note

NETWORK
Modified the default value of AT+QNWCFG=“dis_4MIMO_enable” to 1, and
solved the problem that the configuration might not take effect

you might want to update to see if it fixes the issue

Hello. I would like to get the latest firmware for the RM502Q-GL module. Here is a screenshot of the AT+QGMR command. Thanks!

RM502QGLAAR11A02M4G_01.001.01.001.zip

1 Like

Hello all

I have a ZyXEL NR7101 which came with RG502QEAAAR11A03M4G installed.

How can I upgrade to the latest (RG502QEAAAR13A03M4G? / RG502QEAAAR13A02M4G ??).

I’ve tried using the files here but the ZyXEL won’t accept it (“illegal image”, even with the SIM card removed as advised here)

you can’t use that, if you are on OEM firmware, you need to use dfota made for zyxel, and actually you can only go to R11A07, there is no R13A02 Dfota available yet.
Those R13A02 zip file are not dfota, but full firmware, you need Qflash , in the case of the zyxel, you must use QFirehose to install but you can’t on OEM, you need to install openwrt for that.

Thanks, could you help me understand exactly how to do that or which files to use?

Hello. I am not able to download this firmware. Would you please share it again so I can download?

Thanks.

RM502QGLAAR11A02M4G_01.001.01.001 sent to you by email

Thank you very much.

Hello @herbert.pan-Q ,
could you also provice me with the latest firmware for RM502Q-AE? My current version is:

Revision: RM502QAEAAR11A04M4G
and
Revision: RM502QAEAAR11A02M4G
on the even older modems.
With kind regards!

RM502QAEAAR11A02M4G has sent by email,but RM502QAEAAR11A04M4G not found