EP06-E over USB identified as 05c6:9008

I’m trying to understand what is wrong with my setup. I’m testing my new EP06-E (with help of USB adapter) to verify it works.

Issue just is that it’s identified as:

idVendor 0x05c6 Qualcomm, Inc.
idProduct 0x9008 Gobi Wireless Modem (QDL mode)

I would assume that even without right drivers, I should see it as 2c7c:0306 right? I also tried to cover USB 3 TX/RX pins, but that didn’t help. I also only get 1 ttyUSB0 port, no idea which (DM/AT/…) port it is.

[620663.144709] usb 1-1.4: new high-speed USB device number 23 using xhci_hcd
[620663.247231] usb 1-1.4: New USB device found, idVendor=05c6, idProduct=9008, bcdDevice= 0.00
[620663.247248] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[620663.247260] usb 1-1.4: Product: QUSB__BULK
[620663.247271] usb 1-1.4: Manufacturer: Qualcomm CDMA Technologies MSM
[620663.253975] qcserial 1-1.4:1.0: Qualcomm USB modem converter detected
[620663.254303] usb 1-1.4: Qualcomm USB modem converter now attached to ttyUSB0

Is device in failure state? Have I been sold real looking fake? Or I have done something wrong? Should I be able to get some sign of life with USB2 only?

Or are these sold without any firmware?

And output of lsusb -v

Bus 001 Device 023: ID 05c6:9008 Qualcomm, Inc. Gobi Wireless Modem (QDL mode)
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            0
  bDeviceSubClass         0
  bDeviceProtocol         0
  bMaxPacketSize0        64
  idVendor           0x05c6 Qualcomm, Inc.
  idProduct          0x9008 Gobi Wireless Modem (QDL mode)
  bcdDevice            0.00
  iManufacturer           1 Qualcomm CDMA Technologies MSM
  iProduct                2 QUSB__BULK
  iSerial                 0
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength       0x0020
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0
    bmAttributes         0xa0
      (Bus Powered)
      Remote Wakeup
    MaxPower                2mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           2
      bInterfaceClass       255 Vendor Specific Class
      bInterfaceSubClass    255 Vendor Specific Subclass
      bInterfaceProtocol    255 Vendor Specific Protocol
      iInterface              0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x01  EP 1 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
Device Qualifier (for other device speed):
  bLength                10
  bDescriptorType         6
  bcdUSB               2.00
  bDeviceClass            0
  bDeviceSubClass         0
  bDeviceProtocol         0
  bMaxPacketSize0        64
  bNumConfigurations      1
can't get debug descriptor: Resource temporarily unavailable
Device Status:     0x0000
  (Bus Powered)

Dear Alump,
Thanks for your inquiry in Quectel forum.
For your issue, the module may already enter into emergency download mode, it is abnormal.
You’d better to check whether you use the right Minipcie board matched with EP06 module, and it is better to provide your test picture or video which contains the device connection, the module connections. Then we can help you to solve the issue. Also you should install the right USB driver in your PC. Thanks!

Google Photos

My setup is really simple right now. Just USB2->mPCIe adapter (cheap AliExpress device) connected to my Raspberry Pi 4 via USB 2. The kaptom tapes are there to cover USB 3 connectors - but it behaved same way without those two tapes.

This setup is just to verify that EP06-E is working, as I don’t yet have the device where I will be using this device.

Could this “emergency download mode” be caused by:

  • weak power supply on this adapter
  • SIM card not getting network, or having PIN code? (I used old prepaid sim I had, just to put something in, but would have expected it cause issue only later when trying to open connection)
  • Or just this usb->mpcie thingy not being compatible with EP06-E

USB connection itself should provide enough current. I tested with also with my OpenWRT based router, that should be able to push more current to USB ports. But it behaved same way as Raspberry Pi.

Dear Alump,
Thanks for your updating.
What i said “emergency download mode” is just my guess, it need to double check it.
Please double check whether the following board is matched EP06 minipcie interface. Thanks!

You can see that the problem is wider and I have the same problem exactly identically identified - thread below

EP06-E problem Windows and Mikrotik

I bought the EP06-E module, unfortunately after installation under Windows I can only see in Com & LPT

Quecyel QDloader 9008 COM3

under Mikrotik
0 1-0 Linux 3.3.5 ehci_hcd RB400 EHCI 480
1 1-1 Qualcomm CDMA Technolo … QUSB__BULK 480

What can I do with it so that widndows and Mikrotik see this card?

Please double check the following information. Thanks!

Google Photos

To me these should be right pins? Right? I even tried to adjust my tapes, as the right one was little off, but it didn’t help. Device still shows up as 05c6:9008.

Dear Alump,
I think the module pin is right. Have you check whether the bottom board you used is the same as EPXX EVB, i means the pins. I think you should use the correct bottom board, then if it is still have the issue, it maybe the module issue, we need more information to analyze it. Thanks!


Well, as mentioned… it’s a cheap USB->mPCIe board. So no luck to find any schematics, but here are images:

Google Photos

Did some multimeter testing, 2 and 4 are not connected, but 24 and 26 are. I think other grounds (than 4) were connected. But yeah after this it gets harder, I think USB 2s are behind capacitors as in your model board. I think all the special pins (WAKE etc) are just floating. SIM pins I didn’t test.

I ordered another cheap board, just to eliminate possibility that issue is with this board.

Does anybody know any cheap boards that do actually are known to work with EP06? EVBkit would be overkill for my use case (which right now is to know if this module works or not).

In order to make sure the module can work on normally, it is better to use the matched EVB board, not cheap boards. Thanks!

@alump, @arni, I’m having same problem with this modem on some platforms. Long story short, it seems there is a hardware related issue on the EP06 W_DISABLE# signal handle. Covering this pin on the card solves the problem for me.

What’s more, both the W_DISABLE# and PERST# signals are in 1V8 domain and there is no pull-up resistor on W_DISABLE# line (defined as required in standard). All of that is not compliant with the mini PCIe standard.

Thanks for an idea, but it didn’t help for me. I think those pins were floating (NC) on my board already.

Maybe that’s the problem, I would definitely try adding pull-up resistor on W_DISABLE# and PERST# lines then. Have a look at recent PC Engines apu4d board revision change (source: https://www.pcengines.ch/apu4d4.htm):

"Add series resistor to W_DIS# signal on miniPCI express to support Quectel EP06 modules."

Yes, that sounds like thing I should try out. So both should be pulled up to 1.8V, right?

Hi to All.
Question is what’s the resistor OM we should use.

At “Hardware Design” we can read:
“3.7.2. W_DISABLE_N Signal*
EP06 module provides a W_DISABLE_N signal to disable or enable the RF function (not include GNSS)
by hardware method or software method. Hardware method can be controlled by W_DISABLE_N signal,
this function is disabled by default, and AT+QCFG=“airplanecontrol”,1 can be used to enable this
function. The details of W_DIABLE_N signal function is as follows:
High Lever | RF enabled | Normal mode
Low Level | RF disable | Airplane mode”
“1) When W_DISABLE_N control function is enabled, RF function can be enabled by pulling
W_DISBLE_N to high level and executing AT+CFUN=1.”

All this give us info that pull-up should not work is we not enable this feature.
But who know’s if it’s not enable from AliExpress seller… who in 90% sell that QDL state the cards.

@arni - He receive a new firmware, he do QFlash and see the finall PASS and after his EP06-E is detect correcly but all COM-s are flapping. He add link to his case upper at your post.

Then we know that are two ways

  • some firmware
  • pull-up resistor

We should not write about any resistors, that modems should be a production, good to ent-user who should just use it and not add resistors.

I have EPXX-EVB and I just measured - both pins are floating there. If you have a Windows machine, I would suggest to try upgrading the firmware first (pm me for link). With a standard adapter like from your pictures I didn’t have any problems, only on some platforms (like apu3a2 with old bootloader and some old 3G industrial router). Maybe your problem isn’t actually the same as mine and in fact your firmware on the modem is broken (thus the QDL mode for emergency upgrade, see: https://www.96boards.org/documentation/consumer/guides/qdl.md.html).

1 Like

I pulled the W_DISABLE_N up, it didn’t change anything. Still shows up as 05c6:9008 with only 1 serial connection. So yeah, maybe I should just try to reflash this thing.

EDIT: Does this forum even have PM feature? I can’t find it. Maybe my account is too new for PMs. :frowning: I do have Windows machine.

User @Arni install QFlash + EP06ELAR03A08M4G and reach the proper detection of module but he receive Flaping of the COM-s and now he cannot re-programing or do anythink with module. Reseller give him this FW. I support him with Router stuff.

@alump - you should try other version then EP06ELAR03A08M4G.

Effect of QFlash + EP06ELAR03A08M4G =

1 Like