BG96 not saving +QCFG="nwscanmode" after reset

We have one board where the BG96 always starts with default “nwscanmode”=0 and default “band” settings.

Each time I power it up I change them, then send “AT+CFUN=1,1” and those options are back at their default values. I also tried a clean powerdown with “AT+QPOWD” but same result.

Since the modem is reset to “nwscanmode”=0, I cannot use NB-IoT effectively, because each time it will restart a new network search and take more than 2 minutes to connect, instead of a few seconds.

Could it be some pin/pad soldering related problem? Is there some “reserved” pin that force the modem not to save those settings, maybe for testing purposes? A bad soldering could pull that pin to GND and activate some hidden “test mode”…

I cannot find a reason why this particular module is not working like all the other BG96 modules we have. They all have the same firmware. I even tried to reload the firmware, hoping it would clear the NV settings storage, but it does not. Is there a way to reset the module to factory settings, or clear the NV storage?

Hi PPescher,

  1. Normally, the settings should be stored in NV value, and the restart is still valid.
    May I know that , this issue occur in one board only ,or all board ?

  2. Try the following command at + qprtpara = 3 to see if it can solve the problem of your module.

  3. The normal flash FW can not change NV , only factory fw version will rewrite the partition of NV .
    Anymore issue , pls send email to , we will setup ticket to track and do more analysis .

Hi Stephen,

Sending “at+qprtpara=3” did the trick! Now “nwscanmode” does not reset to 0 each time I reset or power up the module.
What does that command do? And how did the modem get stuck into that state?


Hi Pescher ,

This Cmd means that restoring factory setting .

I do know what operation has been done in your side , The root cause is that some NV has been changed .

Hi @Stephen.Li-Q
where i can find documentation about the at+qprtpara=3 ?

I can not attached doc here ,pls send email to me . thanks

Hi Stephen Li

I have the same problem, “at + qprtpara = 3” doesn’t work for me, is there another way? The module that I use is EC20



I know it’s a late reply, just wanted to share a possible solution for saving NV.
While I was helping a customer with the NV reset command
Out of mistake the customer has mistyped it as
and it started to retain changed NV items thereafter.
It could have been a coincidence, but might be worth a try.

You may also try to the regular NV write command.
First restore to factory settings via:
Then write the NV via:

Good luck!