BG96 NB-IoT mode private network not working band3

hi
we have private Nokia network, Band 3 spectrum with 20 MHz dedicated assignment for NB-IoT inband signaling.
PLMN is 99920
I am not able to register the SIM card using Quectel BG96.
I have tried the AT commands, as per user guide and followed up few references from the forum,
I will be grateful to have further help from the pro Quectel forum member,


It looks like I am very close,
I am attaching the putty log for the AT commands I have tried,
+QCFG: “nwscanseq”,030201
OK

APP RDY

at

OK

at+cops?

+COPS: 0

OK

at+cgdcont?

+CGDCONT: 1,“IP”,“nbiot”,“0.0.0.0”,0,0,0,0

OK

at+cgatt?

+CGATT: 0

OK

at+creg?

+CREG: 0,0

OK

at+creg=1

OK

at+cfun=1

OK

at+csq

+CSQ: 99,99

OK

APP RDY

at

OK

at+csq

+CSQ: 99,99

OK

at+cpin?

+CPIN: READY

OK

at+qcfg=@

ERROR

at+qcfg=“nwscanseq”

+QCFG: “nwscanseq”,030201

OK

at+qcfg="s

ERROR

at+qcfg=“nwscanseq”,030201

OK

at+qcfg=“nwscanseq”

+QCFG: “nwscanseq”,030201

OK

at+qcfg=“nwscanseq”

+QCFG: “nwscanseq”,030201

OK

at+qcfg=“iotopmode”

+QCFG: “iotopmode”,1

OK

at+qcfg="a

ERROR

at+qcfg=“band”

+QCFG: “band”,0xf,0x3,0x10

OK

at+qcfg=“band”,0xf,0x4,0x4,1

ERROR

at+qcfg=“band”,0xf,0x4,0x4

ERROR

AT+QCFG=“band”,0x0,0x0,0x0

ERROR

at&w

OK

at+qcfg=“band”,0,4,4

OK

at+qcfg=“band”

+QCFG: “band”,0xf,0x4,0x4

OK

at+cops?

+COPS: 0

OK

at+cops=?

+COPS: (1,“999 20”,“999 20”,“99920”,9),(0,1,2,3,4),(0,1,2)

OK

at+qcsq

+QCSQ: “NOSERVICE”

OK

at+qcsq=?

+QCSQ: “NOSERVICE”,“GSM”,“CAT-M1”,“CAT-NB1”

OK

at+qcsq:"CAT-NB-

ERROR

at+qcsq:“CAT-NB1”,-52,-81,195,-10

ERROR

at+qcsq=“CAT-NB1”,-52,-81,195,-10

ERROR

at+csq

+CSQ: 99,99

OK

at+qspn

ERROR

at+qspn=?

OK

at+qspn?

ERROR

at+qspn

ERROR

at+qs

ERROR

at+qcsq=?

+QCSQ: “NOSERVICE”,“GSM”,“CAT-M1”,“CAT-NB1”

OK

at+qcsq=“CAT-NB1”,-52,-81,195,-10

ERROR

at+gsn

860536049415567

OK

based on your at log , pls lock band 3 with the below at cmd

AT+QCFG=“BAND”,0,4,4 // Lock to B3(catm & nb)

to check mor info ,pls send the below at cmd

at+cereg?;+cgreg?;+cops?;+qcsq;+qnwinfo

AT+QMBNCFG=“DEACTIVATE”

AT+QMBNCFG=“autosel”,0

reboot module, then try these command again:

AT+CGDCONT?

AT+CGCONTRDP

AT+COPS?

AT+CIMI

AT+QCSQ

AT+QMBNCFG="LIST‘

AT+QCFG=“emmcause”

for more analysis , we need your help and collect QXDM log 。

further more i tried below, but still device is not scanning the NB iot

at+qcfg=“nwscanseq”,03
at+qcfg=“nwscanmode”,3
at+qcfg=“iotopmode”,1
at+cfun=0
at+cfun=1
at+cops=1,2,“99920”,9
at+qcfg=“band”,0,4,4
at+qcsq=“CAT-NB1”,-52,-81,195,-10
at+cgdcont=1,“IP”,“nbiot”

hi Stephen
thank you for your time
I am trying your suggestions now,
could you please suggest how to reboot the module without unplug it from the usb.
I have the USB pluggable dongle which I am accessing remotely.
Thank you
Abhishek

hi Stephen
Below is the print for the AT commands,
Please ignore the text, it is printing twice due to some reason with putty terminal

OK
aatt++cceerreegg??
+CEREG: 0,2

OK
aatt++ccooppss??
+COPS: 0

OK
aatt++qqccssqq
+QCSQ: “NOSERVICE”

OK
aatt++qqnnwwiinnffoo
+QNWINFO: No Service

OK
aatt++qqmmbbnnccffgg=="“ddeeaaccttiivvee”"
ERROR
aatt++qqmmbbnnccffgg=="“DDEEAACCTTIIVVAATTEE”"
OK
aatt++QQMMBBNNCCFFGG=="“aauuttoosseell”",00
OK

hi Stephen
please find further logs post reboot

OK
aatt++ccggddccoonntt??
+CGDCONT: 1,“IP”,“nbiot”,“0.0.0.0”,0,0,0,0

OK
aatt++ccggccoonnttrrddpp
OK
aatt++ccooppss??
+COPS: 0

OK
aatt++cciimmii
999200000000000

OK
aatt++qqccssqq
+QCSQ: “NOSERVICE”

OK
aatt++qqmmbbnnccffgg=="“LLIISSTT”"
+QMBNCFG: “List”,0,0,0,“Att_Non_Volte_Lab”,0x05010310,201712191
+QMBNCFG: “List”,1,0,0,“China_Common”,0x05802800,201806231
+QMBNCFG: “List”,2,0,0,“ROW_Commercial”,0x05800801,201806301
+QMBNCFG: “List”,3,0,0,“Verizon_Commercial”,0x05803801,201806301
+QMBNCFG: “List”,4,0,0,“Telstra_Commercial”,0x05801806,201903191
+QMBNCFG: “List”,5,0,0,“SKT_Commercial”,0x05804803,201907061

OK
aatt++qqccffgg=="“eemmmmccaauussee”"
OK

please advise how to enable or collect QXDM logs
thank you