BG95-M6 - registration in network (NB-IoT)

Hello,
i am currently playing with module BG95-M6 and i can not register module to network i used all possible commands and no succcess. Can someone provide me some advice?

I am able to see available operator with AT+COPS=? command, but when i forced connect, then i got error responce.

Any advice will be blessing for me. :slight_smile:

Log:
uart:~$ at send at
ok: at
uart:~$ at send AT+CFUN?
ok: AT+CFUN?
+CFUN: 1
uart:~$ at send AT+CPIN?
ok: AT+CPIN?
+CPIN: READY
uart:~$ at send AT+CPAS
ok: AT+CPAS
+CPAS: 0
uart:~$ at send ‘AT+QCFG=“nwscanseq”’
ok: AT+QCFG=“nwscanseq”
+QCFG: “nwscanseq”,020301
uart:~$ at send ‘AT+QCFG=“nwscanseq”,03’
ok: AT+QCFG=“nwscanseq”,03
uart:~$ at send ‘AT+QCFG=“nwscanseq”’
ok: AT+QCFG=“nwscanseq”
+QCFG: “nwscanseq”,030201
uart:~$ at send ‘AT+QCFG=“iotopmode”’
ok: AT+QCFG=“iotopmode”
+QCFG: “iotopmode”,1
uart:~$ at send ‘AT+QCFG=“band”’
ok: AT+QCFG=“band”
+QCFG: “band”,0x0,0x100002000000000f0e189f,0x80000
uart:~$ at send ‘AT+QCFG=“nb/bandprior”’
error: AT+QCFG=“nb/bandprior”
uart:~$ at send ‘AT+COPS=?’ ‘’ 260000
ok: AT+COPS=?
+COPS: (1,“Vodafone CZ”,“Vodafone”,“23003”,9),(0,1,2,3,4),(0,1,2)
uart:~$ at send ‘AT+COPS=1,0,“Vodafone CZ”,9’ ‘’ 50000
error: AT+COPS=1,0,“Vodafone CZ”,9
uart:~$ at send ‘AT+COPS=1,1,“Vodafone”,9’ ‘’ 50000
error: AT+COPS=1,1,“Vodafone”,9
uart:~$ at send ‘AT+COPS=1,2,“23003”,9’ ‘’ 50000
error: AT+COPS=1,2,“23003”,9
uart:~$ at send ‘AT+QCSQ’ ‘’ 50000
ok: AT+QCSQ
+QCSQ: “NOSERVICE”
uart:~$ at send ‘AT+COPS=0’ ‘’ 260000
ok: AT+COPS=0
uart:~$ at send ‘AT+QCSQ’ ‘’ 50000
ok: AT+QCSQ
+QCSQ: “NOSERVICE”
uart:~$ at send ‘AT+QCSQ’ ‘’ 50000
ok: AT+QCSQ
+QCSQ: “NOSERVICE”
uart:~$ at send ‘AT+QCSQ’ ‘’ 50000
ok: AT+QCSQ
+QCSQ: “NOSERVICE”
uart:~$ at send ‘AT+QCSQ’ ‘’ 50000
ok: AT+QCSQ
+QCSQ: “NBIoT”,-75,-84,142,-9
uart:~$ at send ‘AT+QCSQ’ ‘’ 50000
ok: AT+QCSQ
+QCSQ: “NBIoT”,-75,-84,142,-9
uart:~$ at send ‘AT+QCSQ’ ‘’ 50000
ok: AT+QCSQ
+QCSQ: “NBIoT”,-75,-84,142,-9
uart:~$ at send ‘AT+QCSQ’ ‘’ 50000
ok: AT+QCSQ
+QCSQ: “NBIoT”,-75,-84,142,-9
uart:~$ at send ‘AT+QCSQ’ ‘’ 50000
ok: AT+QCSQ
+QCSQ: “NBIoT”,-75,-84,142,-9
uart:~$ at send ‘AT+QCSQ’ ‘’ 50000
ok: AT+QCSQ
+QCSQ: “NBIoT”,-75,-84,142,-9
uart:~$ at send ‘AT+QCSQ’ ‘’ 50000
ok: AT+QCSQ
+QCSQ: “NBIoT”,-75,-84,142,-9
uart:~$ at send ‘AT+QCSQ’ ‘’ 50000
ok: AT+QCSQ
+QCSQ: “NBIoT”,-75,-84,142,-9
uart:~$ at send ‘AT+QCSQ’ ‘’ 50000
ok: AT+QCSQ
+QCSQ: “NBIoT”,-75,-84,142,-9
uart:~$ at send ‘AT+QCSQ’ ‘’ 50000
ok: AT+QCSQ
+QCSQ: “NOSERVICE”
uart:~$ at send ‘AT+QCSQ’ ‘’ 50000
ok: AT+QCSQ
+QCSQ: “NOSERVICE”
uart:~$ at send ‘AT+QCSQ’ ‘’ 50000
ok: AT+QCSQ
+QCSQ: “NOSERVICE”
uart:~$ at send ‘AT+QCSQ’ ‘’ 50000
ok: AT+QCSQ
+QCSQ: “NOSERVICE”
uart:~$ at send ‘AT+COPS=1’ ‘’ 260000
error: AT+COPS=1
uart:~$ at send ‘AT+COPS=?’ ‘’ 260000
ok: AT+COPS=?
+COPS: (1,“Vodafone CZ”,“Vodafone”,“23003”,9),(0,1,2,3,4),(0,1,2)

pls send the below at amd and waiting

Since NB network band scan need long time , so when you register network first time , pls waiting , about 34 mins for first times

  1. AT+QPRTPARA=3 //restore factory setting
  2. AT+QCFG=“NWSCANSEQ”,03 // config to search NB network first
    3.AT+QCFG=“nwscanmode”,3 //LTE ONLY
  3. AT+QCFG=“iotopmode”,1 //LTE Cat.NB1 only 9
    5.AT+cfun=0
    6.AT+cfun=1

waiting

Hi, I am surprised this did not work. Anyway, try
AT+QCFG=“iotopmode”,1,1
AT+QCFG=“band”,0x0,0x0,0x80000
that should limit the module to NB in B20 which Czech Vodafone uses.

P.S.: nwscanseq+nwscanmode is a good idea as well,
try AT+QNWINFO and AT+CEREG=4;+CEREG=? to query the state.

Hello thanks for responce,
device was previously used at Belgium, so PDP context was set wrong. I set pdp context with AT+CGDCONT=1,“IPV4V6”,"" and after that i am able to register SIM into Vodafone network. and communicate with our server.

I not have so much knowledge in this area so i am happy that this works.