[BC95-G] AT+CFUN=1 returns CME ERROR 4


I’m using a BC95-G connected via QCOM (1.6). I keep on being confronted with CME ERROR: 4 when trying to set CFUN = 1. See log below.

In another related topic I’ve seen that the suggested remedy is to upgrade the firmware. Would that be recommended in my scenario too? If so, where do I get this firmware upgrade? Send an email?

Many thanks!

[2022-01-05_16:49:26:348]Boot: Unsigned
[2022-01-05_16:49:26:348]Security B.. Verified
[2022-01-05_16:49:26:518]Protocol A.. Verified
[2022-01-05_16:49:29:368]Apps A...... Verified

[2022-01-05_16:49:40:689]+CME ERROR: 524


[2022-01-05_16:49:53:679]+CME ERROR: 524
[2022-01-05_16:50:02:011]+CME ERROR: 4

[2022-01-05_16:50:08:507]+CME ERROR: 524

Please check that your SIM’s contacts are clean, and that the SIM is mounted correctly.

The errors are from commands requiring the modem to have SIM access.

Hi @snowgum , thanks for the suggestion. I’ve cleaned the SIM, tried it with three different NB IoT SIM’s (fresh from the supplier, should work out of the box). I’ve also tried it with SIM’s from a different telecom provider, so now I’ve tried both T Mobile & Vodafone.

I’m using a Dragino BC95-G module that previously (a few months ago) worked just fine, with some of the same SIMs (Vodafone ones).

Indeed based on the error codes it seems like all of this is SIM related, but there isn’t much more I can do about that. Could it be that maybe the BC95-G has somehow blocked the SIM cards?

I resolved the problem. Turns out the SIM card was the wrong way round. :man_facepalming: I had the chamfered corner pointing inwards instead of outwards… See recommendation image below.

I do find it very counterintuitive. You would expect the chamfered corner to fulfil some kind of function for the internal spring mechanism, therefore it would make sense that it faced inwards. Not outwards (where it fulfils no function at all, except for being a visual marker).