Bad work Quectel EM160R-GL in MBIM/QMI mods

Hello! I have a Quectel EM160R-GL with firmware EM160RGLAUR02A07M4G and want to use it in Mikrotik RBM33G. I set modem to MBIM mode, he started successfully, but sometimes there is a disconnect. Can You please, say, what i can do to fix it?
When disconnected, I restart LTE-interface and wait 5…7sec and the connection is repaired and works successfully.
Same picture I can see on my laptop with Windows 10. Also with win10 x64 there is the same situation, bad work modem in MBIM and ECM mode. I use drivers v.2.2.4 and in this mode network adapter every 5…7sec disappears from network adapters and there is no connection :frowning:. So with Win10 x64 I can use only QMI mode, but in QMI I have the same problem with disconnect.

I had written to Mikrotik support. They say this:
This looks like a modem firmware issue, before the connection is lost modem does not respond to RouterOS request like:
2021.04.23-14:44:26.06 @@net@@ @0 lte1 mbim: error: function error: not opened
Apr/23/2021 17:44:27 lte,error lte1: reply timeout for: AT+QENG=“servingcell”
This looks the same as an issue we reported to Quectel for another modem model.
Please check for modem firmware upgrade and update it when it is available.

In OpenWRT I can’t check this module because there are no drivers for EM160R-GL to work with OpenWrt (or I can’t find it).
So I have a nice module that can’t work stable in any mode, what can I do?

2 Likes

Hi Sir,

It is the lastest Firmware version.

Normally it is the network issue. Please check the module with some commands

AT +CFUN?
AT+CSQ
AT+CREG?
AT+CEREG?
AT+COPS?

Quectel offer the source code for Linux driver and dial up tools, you’d porting it in your OpenWrt SDK.

quectel-CM for dialing up
https://drive.google.com/drive/folders/1anUUbUkLWARPzEKQuaJvqahk1MTLH4nf?usp=sharing

kernel driver
https://drive.google.com/drive/folders/1sMrU8ZpYxx5s6ZJ6NPSxtR2C9uUEbbQL?usp=sharing

If any difficulty in OpenWrt, you can ask in the OpenWrt forums and ask us to answer there. And there are many other developers have applied Quectel Modules in OpenWrt successfully.

btw, it’s better to contact with the local sales or local FAE, or send email to support@quectel.com for help.

1 Like

That’s 99,99% wrong, I used before EM160R-GL other module in ECM mode, Quectel EP06-E and there are no problems with it.
What about work in MBIM in Windows? How I know MBIM is the best to work with Windows 10.

AT+CFUN?
AT+CFUN?<CR>
+CFUN: 1

OK
AT+CSQ
AT+CSQ<CR>
+CSQ: 25,99

OK
AT+CREG?
AT+CREG?<CR>
+CREG: 0,1

OK
AT+CEREG?
AT+CEREG?<CR>
+CEREG: 0,1

OK
AT+COPS?
AT+COPS?<CR>
+COPS: 0,0,"MegaFon MegaFon",7

OK

Thank You! I will try to test this drivers with OpenWRT this week!

I also had written to support@quectel.com and what they answered to me:

Hi Denis,

Thanks for the info.
Allow me to introduce you Quectel Technology Forum (https://forums.quectel.com), our dedicated technical forum for individual users. Would you please post your question details there? Our engineer there will take care of your question. Cheers!

there’re no drivers for other modems as well - support is provided by using common MBIM and QMI protocols
Try to establish a connection using qmicli (qmi-network) or mbimcli (mbim-network).

Same problem here.
Em160R-gl + Microtik LHGG (RBLHGGR).
I randomly get this error.


Any solution?

Same problem here… with EM160RGLAUR02A07M4G

I also tried within raspios, mbim and qmi … same thing.

Random disconnections …

– I then tried an Engineering Sample one, and everything is ok.

2 Likes

Today i tested this module with windows 10 x64 in MBIM mode. I deleted Quectel drivers 2.2.4(find it on this forum) from my pc and default driver of windows 10 worked with EM160R-GL in MBIM mode correctly.
And there is the same problem. Network adapter was disconnected and connected again. Connection was losted. I load a log from AirScreen here:


Possible, You can see what the problem is.

Same problem here with EM160RGLAUR02A07M4G

Any solution?

Thank you!

1 Like

Maybe reflash firmware can help with this? Is it possible to link me files, so that I can reflash firmware on my EM160R-GL? Now it’s EM160RGLAUR02A07M4G.
And is EM160R-GL supported by ESIM? If yes, can You please link me to the instruction, where I can read how I can activate ESIM on this module.

In my case flashing another firmware didn’t help. I tried the 05 firmware and the 07 again.
I know people with the engeneering sample of the module and they have no disconnections.
I don’t know if a new firmware could fix this problem…

@Bean.Wang-Q do you have any news for us?

is that a problematic batch of modems? could you tell us how we can identify them?

Thank you

Please provide the Modem Log.

Here is the log @Bean.Wang

@Bean.Wang-Q I had linked the log file some time earlier. This log from modem, when modem stay in Windows 10 x64in MBIM mode

As what you said, it might be regarded as firmware bug.

Please contact with the local sales.

Till now, EM160RGLAUR02A07M4G is the lastest version.

@Bean.Wang-Q, what about eSIM? How can I connect my eSIM to this module? How i see, it’s supported
And what diagnostic packages You need to see, to understand why this bug is?

Они не могут помочь даже с EM12, а этот модем совсем новый.

Good fun :slight_smile: but I think Quectel support don’t understand russian.

So, let me translate:
They can not solve the problem with EM12-G even, and your modem is brand new.


You may read the neighbour topic about the bug in EM12-G, that Quectel can not solve during monthes :slight_smile:

1 Like

Мой EM12-G на RB951 не завелся в MBIM, в логах он писал что-то про таймауты и wdm… Я не вникал, так как списал это на beta прошивку mikrotik. В винде драйверы quectel для разных режимов поставленные одновременно вызывают “танцы” сетевого адаптера. На всякий случай проверьте, что реально все снесено и поставьте драйверы для чего-то одного либо базовые QMI, либо MBIM, либо RNDIS. Если ничего не помогает, тогда добро пожаловать в quectel-клуб “танцы с бубнами” :slight_smile:

1 Like

Господи как сними сложно! Есть хоть один нормально кто объяснить? Есть русскоговорящие? Неужто так сложно соединить циферки и объяснить я ведь уже всё нарисовал нужно только сказать какую цифру, с какой соединить, когда одна антенна и когда две антенны. Такое впечатление, что техподдержка сама не знает, как подключаются антенны пишут как Нострадамус хрен чего поймёшь! Ну же парни подскажите, кто шарит я так с ними ещё неделю бодаться буду!

1 Like