Anyone who has worked with RM500U-CN?

Please repeat with ls -l to show the file size.

pi@ubuntu:~/Quectel/try-2/RM500U_FOR_RPI_Ubuntu22.04/option$ ls -l
total 1964
-rwxrwxrwx 1 pi   pi      341 Nov 23 10:29 Makefile
-rw-r--r-- 1 root root   1348 Feb 27 14:09 Module.symvers
drwxrwxrwx 3 pi   pi     4096 Nov 23 10:29 drivers
-rw-r--r-- 1 root root    211 Feb 27 14:09 modules.order
-rwxrwxrwx 1 pi   pi   133411 Nov 23 10:29 option.c
-rw-r--r-- 1 root root 403628 Feb 27 14:09 option.ko
-rw-r--r-- 1 root root     69 Feb 27 14:09 option.mod
-rw-r--r-- 1 root root  79290 Feb 27 14:09 option.mod.c
-rw-r--r-- 1 root root 220576 Feb 27 14:09 option.mod.o
-rw-r--r-- 1 root root 185816 Feb 27 14:09 option.o
-rwxrwxrwx 1 pi   pi    17546 Nov 23 10:29 qcserial.c
-rw-r--r-- 1 root root 215992 Feb 27 14:09 qcserial.ko
-rw-r--r-- 1 root root     71 Feb 27 14:09 qcserial.mod
-rw-r--r-- 1 root root   9484 Feb 27 14:09 qcserial.mod.c
-rw-r--r-- 1 root root  50952 Feb 27 14:09 qcserial.mod.o
-rw-r--r-- 1 root root 167828 Feb 27 14:09 qcserial.o
-rwxrwxrwx 1 pi   pi     1982 Nov 23 10:29 usb-wwan.h
-rwxrwxrwx 1 pi   pi    16866 Nov 23 10:29 usb_wwan.c
-rw-r--r-- 1 root root 220228 Feb 27 14:09 usb_wwan.ko
-rw-r--r-- 1 root root     71 Feb 27 14:09 usb_wwan.mod
-rw-r--r-- 1 root root   2031 Feb 27 14:09 usb_wwan.mod.c
-rw-r--r-- 1 root root  32352 Feb 27 14:09 usb_wwan.mod.o
-rw-r--r-- 1 root root 195716 Feb 27 14:09 usb_wwan.o

OK, the drivers were built but not copied.
You need to copy *.ko from this directory to the 1st one you opened, but make a backup copy of the old files.
Then reboot, open a terminal and send at+qnetdevctl=1,1,1 to the modem, show the command output (if any). Then you can try DHCP, etc.

pi@ubuntu:~$ ls -l /lib/modules/$(uname -r)/kernel/drivers/usb/serial/ | grep usb
-rw-r--r-- 1 root root  17481 Jan 18 14:58 ir-usb.ko
-rw-r--r-- 1 root root  14473 Jan 18 14:58 kl5kusb105.ko
-rw-r--r-- 1 root root  12313 Jan 18 14:58 metro-usb.ko
-rw-r--r-- 1 root root  35009 Jan 18 14:58 ti_usb_3410_5052.ko
-rw-r--r-- 1 root root  13725 Jan 18 14:58 usb-serial-simple.ko
-rw-r--r-- 1 root root   6641 Jan 18 14:58 usb_debug.ko
-rw-r--r-- 1 root root 220228 Mar 21 22:12 usb_wwan.ko
-rw-r--r-- 1 root root  67625 Jan 18 14:58 usbserial.ko
pi@ubuntu:~$ ifconfig usb0
usb0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet  netmask  broadcast
        inet6 fe80::4865:daff:feda:e104  prefixlen 64  scopeid 0x20<link>
        ether 4a:65:da:da:e1:04  txqueuelen 1000  (Ethernet)
        RX packets 161  bytes 9900 (9.9 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 261  bytes 32340 (32.3 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

pi@ubuntu:~$ ping -I usb0
PING ( from usb0: 56(84) bytes of data.
From icmp_seq=1 Destination Net Unreachable
From icmp_seq=2 Destination Net Unreachable
From icmp_seq=3 Destination Net Unreachable
From icmp_seq=4 Destination Net Unreachable
--- ping statistics ---
4 packets transmitted, 0 received, +4 errors, 100% packet loss, time 3005ms


and the terminal output please

I am currently using RNDIS mode so I don’t think I need to run that?

My understanding you need it in either case and I suggest switching to ECM.

OMGGG! I switched to ECM and ran that command and it’s working now.

Ok, now


When the modem is back just run your DHCP client and see whether it will work without additional commands.

I just realised that I suggested the wrong sequence of commands in my earlier post.
Reset command should be used before at+qnetdevctl, not after and at+qnetdevctl should be issued after the modem is back after reset.

One more thing to mention: the new drivers produced by the Waveshare script are too big, you can compare the sizes between the old and new files. Their build script probably needs some tweaking but that is outside of my area of expertise.

What does this command do? Looks like this command is what enables it to work.

Yup. It works after I run these followed by the DHCP client.


Thank you for checking.
The command is described by Quectel as 该命令用于执行/断开PDP 拨号。

This command is used to perform/disconnect PDP dialing (Google translate)


1 Like

Does this work both for 4G and 5G? I saw somewhere where it mentions this makes a call for 4G connection. And this coincides with my current issue that I am not able to register or connect to a 5G network after I put in 1,3,1 for at+qnetdevctl followed by a reset.

What contexts have you got defined?


From looking at the documentation above, I’d be trying AT+QNETDEVCTL=3,1,0 if I had one of these modems.

Only 1 and 11. APN on 1 is the operator name and APN 11 is ims, which I don’t need. So 1,3,1 seems like the only option.

I need it to work on startup so I need the second parameter to be 3 anyways. Also the order of the parameters seem to be different from what I saw online. at+qnetdevctl=? shows (1-11), (0-3), (0,1)


Context ID is the second argument, so I recommend trying 1 for that.

3 in the first argument means:

Make a call and automatically remake a call after disconnecting from the network, and automatically make a call after startup

If I do that it creates a new pdp context 3 with a null APN name. Mind you, with 1,3,1 I am getting the desired dialup on startup and I am able to connect to the internet. But it’s only working with LTE. And it’s not registering to 5G even when under a 5G coverage area.

That’s a strong indication that the command syntax is different on your modem from that on the EG060V the documentation refers to.

I’m not aware of any dependency between this command and RAT (3/4/5G).

Are you seeing 5G signal in the AT+COPS=? result?

Is your SIM 5G-capable, and proven to be in another device?