Anyone who has worked with RM500U-CN?

I have been trying to reach the support and they are too slow to reply. I need immediate help with this module. If someone can please help me with this problem:

pls run the AT Command


Running this returns 0,1. But it still doesn’t connect me to the internet. In the case my area doesn’t have a 5G network coverage why am I not able to connect it to 4G?

You need to configure the corresponding APN(AT+CGDCONT=) and activate it(AT+QIACT=)

So I did,




pls run


pls try

Both of them run successfully. Now what should I do?



pls run continuely


Heres the output,

+CGPADDR: 1,""
+CGPADDR: 2,""
+CGPADDR: 4,""
+CGPADDR: 11,""

+CGDCONT: 1,"IP","UNINET","",0,0,0,0,,,,,,0,,,0,,0,0,0,0
+CGDCONT: 2,"IPV4V6","","",0,0,0,2,,,,,,0,,,0,,0,0,0,0

This still returns 8,99 on AT+CSQ. And DHCP couldn’t collect an IP.

What protocol is this modem running? What does AT+QCFG="usbnet" return?

It returns ‘’’ “usbnet”,1 ‘’’

I was following this,

That should be ECM mode, which is set specifically in that guide you’re following.

There have been many reports on other forums of ECM mode not working with certain modem + SIM + provider combinations.

I once raised that issue on this forum, but the discussion did not progress.

Please see what protocols are supported using the AT+QCFG=? command.

Look for a line in the result beginning +QCFG: “usbnet”, like this:

+QCFG: "usbnet",<0-3>

and report the result. We might need to try another protocol.

Caution is required here. We don’t want to lose access to your AT command port by using an inappropriate value.

AT+QCFG=? returns,

+QCFG: "usbnet",(1,3,5)
+QCFG: "nat",(0-2)
+QCFG: "usbcfg",(1-65535),(1-65535),(0,1),(0,1),(0,1),(0,1),(0,1),(0,1),(0,1)

I have tried it changing it to RNDIS here’s the result,

I was hoping to see 0 (QMI) and 2 (MBIM) as possibilities for “usbnet” .

But you’re restricted to 1, 3 and 5.

Sadly, I have no experience with either 3 or 5, and can’t offer constructive suggestions at this point.

I take it you’re trying now to follow the instructions for RNDIS mode in your Raspberry Pi guide.

I have actually tried all three modes till now to get it working. As of now, I am out of options. RNDIS was the one I was trying to get working in the first place.

In RNDIS mode, what result do you get from the AT+CGCONTRDP=1 command?

I’m going through notes I made years ago (for MBIM mode on Fedora Linux).

Assuming IPv4, you should get something like:

+CGCONTRDP: 1,5,connect,,,,

Where “connect” is your APN, “” is your IP address, and “” and “” are your provider’s DNS server addresses.

Using your own value for your IP address, try:

ip addr add brd + dev wwan0
ip route add default dev wwan0

You may also need to set up those DNS server addresses in your /etc/resolv.conf file.

It’s possible that will work for you.

PS - My references to wwan0 in the above may be usb0 for you.

This is the AT output,

+CGCONTRDP: 1,5,UNINET.mnc053.mcc405.gprs,,,,,,,,,1358,,0,,,,0,1,0,0,00

My interface was usb0 so I interchanged wwan0 with usb0 and the IP

This is my /etc/resolv.conf,

pi@ubuntu:~$ cat /etc/resolv.conf
# This is /run/systemd/resolve/stub-resolv.conf managed by man:systemd-resolved(8).
# Do not edit.
# This file might be symlinked as /etc/resolv.conf. If you're looking at
# /etc/resolv.conf and seeing this text, you have followed the symlink.
# This is a dynamic resolv.conf file for connecting local clients to the
# internal DNS stub resolver of systemd-resolved. This file lists all
# configured search domains.
# Run "resolvectl status" to see details about the uplink DNS servers
# currently in use.
# Third party programs should typically not access this file directly, but only
# through the symlink at /etc/resolv.conf. To manage man:resolv.conf(5) in a
# different way, replace this symlink by a static file or a different symlink.
# See man:systemd-resolved.service(8) for details about the supported modes of
# operation for /etc/resolv.conf.

options edns0 trust-ad
search .
pi@ubuntu:~$ sudo dhclient -v usb0
Internet Systems Consortium DHCP Client 4.4.1
Copyright 2004-2018 Internet Systems Consortium.
All rights reserved.
For info, please visit

Listening on LPF/usb0/b6:8b:56:52:cf:f8
Sending on   LPF/usb0/b6:8b:56:52:cf:f8
Sending on   Socket/fallback
DHCPDISCOVER on usb0 to port 67 interval 3 (xid=0x3833111a)
DHCPDISCOVER on usb0 to port 67 interval 4 (xid=0x3833111a)
DHCPDISCOVER on usb0 to port 67 interval 5 (xid=0x3833111a)

What is the output of AT+QCFG="ethernet" ?