5g ethernet rj45 passthrough rm520n-gl

I am interested in this board for a rm520n-gl module:

the vendor tells me it is not possible to use the rm520n-gl module for the rj45 gigabit because only the rm500q-gl supports 5g to lan Gbps. Whatever that means…
I just got basic knowledge of the quectel modems and cellular modems so far, but I would like to ask if and how it might be possible to get the wan to lan working with the rm520n-gl. Would I have to switch the module to ecm mode? And/or to pcie-mode? I don’t know how it is accomplished that the module will pass wan to the rj45 port - and how about sim pin and apn setting?
Thank you for your input!

See Sending AT commands to the RM520N-GL - #5 by mpmic
and RM500Q-GL PCIe RGMII Interface Slower than QMI

So do I understand this correctly that the module has to be set to pcie mode with these commands?

AT+QCFG=“data_interface”,1,0: switch the module to PCIe interface.
AT+QCFG=“pcie/mode”,1: set the module to PCIe RC mode.

To send AT commands over ethernet (e.g. to unlock pin and set apn) this has to be specified as well?

AT+QETH=“eth_driver”,“R8168”,1: load the driver for RTL8111H TE-A.
AT+QETH=“eth_at”,“enable”: enable the driver.

I have got the AT command manual but I can not find any reference on the “AT+QETH” command. Is it supported on rm520n-gl?

My understanding that AT+QETH="eth_driver" is a part of Ethernet mode setup.
For AT commands to work [over Ethernet] one more command is needed according to this post.
Alternatively you can probably use any serial interface like USB or UART.

so where can I find more info on ethernet mode setup?

You can see some examples in the threads I mentioned earlier. For detailed command explanation I suggest asking Quectel.

Follow all the RGMII AT Commands explained on those threads that @jfrog pointed out. Then download the RGMII AT Client to a Linux machine, and open the folder in Terminal… to send commands.

1 Like

Thanks, I still wonder if rm520n-gl does not support ethernet mode? I got all the AT command manuals for rm520n sent by a member of this forum but none of them give a diescription or even mention the RGMII eth commands pointed out in the threads linked above.
In conjunction with the mentioned board I linked in my first post, I wonder if I got the info it is not compatible with rm520 because the ethernet controller might not be compatible. I can not test as I didn’t get the board yet. I got the info that it must be a realtek trl8111 controller.

That’s a very good point. My understanding this is not what you need, it may work but performance will be low.

It does, but you need this other board, and the “r8125” driver enabled on the RM520 by AT Command, with either Qcom or Qnavigator. Make sure the RM520 is already in the rj45 board. Read instructions on that site…

That method is if you do not have the rj45 board near a PC to plug it in via the USB C… Otherwise just send command through usb c port and with Qcom

this is some info, thanks.
But still I can’t find reference for the at+qeth command. Is only driver rtl8125 supported e.g.?

I bought the module. She arrived yesterday. I’m trying to set it up with a rm500q-ae.
The support provided by the seller is very basic
These are the commands he sent me. It is assumed that with this the adapter is left with internet traffic for LAN, however, it does not explain anything else. I’m still struggling with how to up the SIM so that my ISP recognizes it (APN, calling number, etc.)
I send you the commands

Step1: Download the USB driver and install:(Other 5G module please contact the seller)
Step2: Connect the board to PC by USB-C data cable. Use serial/terminal tools to open the AT com port Windows: SecureCRT/MobaXterm/QCOM Linux: minicom/nanocom Step3: set the 5G module to enable the RJ45 port:
1, set USB mode: AT+QCFG=“USBNET”,2
2, set to PCIE mode: AT+QCFG=“data_interface”,1,0
3, set PCIE to RC mode: AT+QCFG=“pcie/mode”,1
4, set the PHY model: AT+QETH=“eth_driver”,“r8125”
5, set the dial mode: AT+QMAPWAC=1

Note, the USB3.0 port and the RJ45 port may not work at the same time. switch to USB port: AT+QMAPWAC=0

For everything else, he always answers that you have to contact the seller of the modem or the AT command manual or some software. I’m trying Qnavigator. If anyone can help me I would appreciate it. Greetings