Wlan0 not showing : wifi issues

Hi ,
I am using Sc20 from quectel in my project. The factory image which is present in the card shows wlan0 when i enter command ifconfig . But , when i push my boot image using fastboot . The wlan0 is not showing on entering ifconfig. This is why I’m unable to bring up wifi.
I am using yocto sc20 sdk from quectel . Can anyone help me on this asap?

Hi, Romil_Verma
Yocto needs the help of our internal R&D. Do you have an account of Quectel’s E-service System? If so, you can create a ticket on it. BTW, what is your company’s name and in which country or region?


Have you some news on this issue ? I’m facing similar problems. I’ve custom the product recipe to remove apps recipes concerning audio, video, qt etc because I use the SC20 only with CLI interface. But now the wifi is not working.

I’ve checked with mod prob and I’ve the following error :
Request for unknown module key ‘Magrathea: Glacier signing key: 63349f7da494480f63fb8ea7f20aefd82c54367a’ err -11
modprobe: ERROR: could not insert ‘wlan’: Required key not available

I can see the kernel is looking for the key signing the module, but I haven’t modifying anything about wifi…

Thank you

You’d better provide some logs.
Such as kernel log and the result you used the wifi Demo.

Hi, i’m facing the same issue on SC20 module. I’ve tried to use your WIFI tool but obviously gone wrong. and i get a segmentation fault error, as you can see in the image below

Hi Mohamed,

Do you used the tool “WIFI” or the wpa_spplicant?
And the system image is built by yourself or from the update package?
If you compile it yourself, you need to compile the overall programming as a whole.
And if you use the update package, what the version do you use?
ifconfig wlan0, can you see the interface wlan0?

I’m using the WIFI tool.
The system image is built by myself but using the build command of your SDK (build-8909-quec-smart-user-image), and then flashed with fastboot.

I’ve tried to use also wpa_supplicant but without wlan0 interface the result is the same, can’t find the interface.

when i try with ifconfig wlan0 i get this output:

ifconfig: wlan0: error fetching interface information: Device not found

You can see the interface wlan0, and there should be something wrong the driver.
From the dmesg log or the debug uart log, you might get some clues. For example, if the /lib/firmware/wlan/prima/WCNSS_qcom_cfg.ini be removed…

Try to flash the update img and see whether it works.
If the update package works, there should be something wrong with the code you modified or the way you built.

Ok, maybe i’ve the wrong SDK or docs, but i can’t find the NON_HLOS_tools dir needed to compile the update package as i’ve read on “Quectel_SC20X_Linux_Startup_User_Guide V1.8.pdf”. Where i can find it?

HON_HLOS.bin is not built by us. It is provided as binary file.
The wifi related binay is in device/qcom/wlan/msm8909.

It is recommended to use the SC20_Linux_R09_r00320.1 but not the SC20X_Linux.
You can get the SC20_Linux_Unpacking_tool_20210113.rar on the FTP server.