Why rm500q-gl cat18 do 5ca and rm500q-gl cat20 only 3ca (LTE)?

I own a rm500q that does only 3ca in lte, but a friend of mine own a rm500q that does 5ca. It is a fw related problem? My fw is RM500QGLABR11A03M4G, he have fw updated to RM500QGLABR11A04M4G but he can’t find the file anymore to do a test with my module. Someone can send me the latest fw in order to test my module?
Many thanks to all the community

edit: his version is cat18, my version is cat20. why the cat20 version can aggregate less bands than cat 18?

Hi Stefano_Macario:
First, I want to make sure that you and your friends are in the same location and use the same service provider.Because CA is the operator using scattered frequency band (adjacent or non-adjacent frequency band) to increase the system bandwidth, to meet the rate increase of single user;Therefore, if your service provider does not have 5CA enabled, your terminal will not be able to implement 5CA applications even if it supports 5CA.
According to your description, your terminal now supports 3CA, indicating that your operator (sim card provider) has implemented at least 3CA support scheme.So you need to do cross validation (including SIM card and terminal).
At the same time, multi-carrier aggregation is also closely related to the radio environment. Due to the possible interference between multi-frequency bands, part of the carriers cannot be measured and added, resulting in the failure to realize the 5CA scenario.
I hope your problem can be solved. If the problem still exists, we will keep communicating with you. Thank you!

i own also em160r and in the same location it does 4ca (not 5ca but 4ca yes) i think that in my firmware version i don’t have the combo 1+3+7+20. So you confirm me that rm500q-gl m20 is able to do 5ca?

Hi, Stefano_Macario:
I am very sorry that I did not inquire relevant technical data for your answer yesterday. Now I inquire our relevant technical data and know that RM500Q-GL can support 3CA at most, but RM502Q-AE in our products can support 5CA capability at present.
If there are any other questions, I hope we can keep in touch. Thank you!

Yes, but in all the datasheets is written cat20 and 5ca for rm500q-gl, in fact all the devices with galbr10 fw do 5ca. It is not correct to sell a device as 5ca and after lock it to 3ca with a fw update in order to sell the new version, especially if the new version has exactly the same modem on it. I think that the fact that rm502q does 2ca in 5g is a good reason to buy it for the future and it is not necessary to lock the rm500q to 3ca. A lot of people noticed this and this move only makes the company look bad. I hope that this problem can be solved in the next fw update.

Hi, Stefano_Macario:
We are very willing to accept your valuable suggestions. In order to better improve our products and serve our customers, we will timely feedback your suggestions.
Thank you!

Can we still get hold of this older firmware? does anyone have a link for it?

Hi,John_Rogers:
Could you please provide your email? I will send it to you by email.

1 Like

John@delosis.com

Thank you, it would be great to have the most recent as well so I can flip back is the reversion to the 10 series doesn’t help my slow LTE speeds.

Hi,John_rogers:
Sorry, the file is too large to be sent by mail. Please download it at the link below,and the latest firmware version is not currently available in the database.
https://quectel123-my.sharepoint.cn/:u:/g/personal/ae-fae_dom_quectel_com_cn/EbrcHyqDKnVIo7o_ya24VCoBau4lBjuda5QVRpMbsTXWEw?e=0HVjSh

Hi - that seems to be the RM500QGLABR11A03M4G firmware which is what I currently have.
The firmware discussed as supporting greater CA in this thread is actually an older one based on the 10 series ( rather than the 11 series ) Is it possible to get a link to one of these older firmware?

Please check the attachment in the link below. Is it what you need
https://quectel123-my.sharepoint.cn/:u:/g/personal/ae-fae_dom_quectel_com_cn/EXH8FtO0h_ZAgyqZDUqEoXEBdD7FYjnRXerEZba18fxJ0A?e=R3H74i

Excellent - thank you.

I see in the release notes for the 11 series firmware that going from 11 back to 10 cannot be done? is this a real problem or just an encouragement not to go back to commercial sample level firmware?

Best,
John

hi,John_Rogers:
It is possible that the firmware version 11 has made a big change in performance, so you are advised to refer to the product design manual.

Thank you for clarification :slight_smile:
What is the proper update channel please?
I checked the windows driver, the link seems broken:https://www.quectel.com/download/quectel_lte5g_windows_usb_driver_v2-1-2/

The card RM500QGLAB-M20-SGASA seems to have similar need, do you have current firmware for this too?

Hi,wir:
Please click the link below to download the driver you need, thank you!
https://quectel123-my.sharepoint.cn/:u:/g/personal/ae-fae_dom_quectel_com_cn/ESEW3vCcmJJBhuvbwFddDYQBbWHxhDKLdMD_on7howeEUw?e=m0idUM

谢谢!:)
Perfect driver.

As for the firmware, it is still RM500QGLABR11A02M4G, can I use the same firmware package as linked above?

https://quectel123-my.sharepoint.cn/:u:/g/personal/ae-fae_dom_quectel_com_cn/EXH8FtO0h_ZAgyqZDUqEoXEBdD7FYjnRXerEZba18fxJ0A?e=xZl4F6

1 Like