Where to get a firmware update for EM12GPAR01A09M4G_MSFT?

On my modem (Quectel EM12-G firmware EM12GPAR01A09M4G_MSFT) IPV6 protocol not work and mobile network connection is unstable, randomly disconnnects. Same situation on Windows and Linux host computers.
Modem EM12-G is powered from external power supply - no voltage drops or glitches on high current consumption.
Mobile network operator - Mobile telesystems OJSC (Russia).
Another modem (huawei e3272) works stable with same SIM-card, and IPV6 protocol works fine.

Can everyone send me a link to latest firmware update for EM12GPAR01A09M4G_MSFT to get more stable mobile connection and get IPV6 protocol work?

Make sure the latest firmware is what you need

1 Like

Thanks for fast reply.
This firmware is not possible to flash to my modem (EM12-G MSFT).
I tries to flash your version, also tries earlier EM12GPAR01A18M4G and EM12GPAR01A17M4G, all unsuccessfull.
I tries use for flashing following tools: QFlash_V4.18, QFlash_V4.19, Quectel_Customer_FW_Download_Tool_V4.48, all unsuccessfull.
In all cases i was get same error: “FAIL,DL_Firehose, Time out!”
Maybe “MSFT” modem has different hardware configuration, and needs special firmware (e.g. EM12GPAR01A14M4G_MSFT) and another flashing tool? Can you give me links, please?

Same problem here
At msft modem version there is no fw for it

Some firmware versions for “EM12-G MSFT” are mentioned here, but no download links (

Please use our latest Qflash tool to upgrade, and there are operation instructions for upgrading the software version of the module in the attached package. At the same time, please do not put the target firmware package in a deep directory, because this may cause the upgrade failure, thank you.

Thanks for last version of Qflash tool.
But flashing with this version is unsuccesfull with same error “FAIL,DL_Firehose, Time out!”.
Firmware path is “D:\Download\EM12GPAR01A21M4G_01.005.01.005”, that is not too long.
Maybe modem EM12-G MSFT requires a different firmware update tool or specific firmware version?

I meet same issue when upgrade EM12G-MSFT using EM12GPAR01A18M4G and EM12GPAR01A17M4G,