Using USB in OpenCPU on BC66

I want to use one of the serial devices available at the USB bus for my own OpenCPU app. I have no idea, how to do this. Can someone give me a hint or an example.

In stock firmware A07 or A10 there are 2 serial devices appear my system after the module has booted. But there seams no functionionality behind this. I tried every possible AND impossible baudrate…

After uploading my own app (out of SDK 1.5) it works flawless on UART_PORT0 which is hardware “main” uart. Meanwhile the both USB serial devices becoming alive and sending a lot trace messages from system @115200 baud.

I tried to modify debug port setting in custom_sys_cfg.c and try all possible uarts from Enum_SerialPort in my app. …no luck

Can someone show me the magic using virtual com port on USB?
Thank you in advance!

I don’t quite understand your question at the moment. Do you want to create a virtual serial port in the Open application?Or something else

Thats exactly, what I want. I had the hope, that it is implemented in the Open-Lib and accessible by a user app. The virtual ports obviously exist in the firmware, but cannot be addressed by the user app. That is my problem.

Can you show me how you do it?For example, show a piece of your code.

I’m asking how to access this port. So I don’t have any code for that.

A change to this location can change which port the LOG information is spit out from.

In addition, the USB of BC66 only supports the capture of log, not other functions, and the USB power supply can not enter the sleep.
I hope my solution is useful to you.