Unable to send message with m95 module


Although I type the AT commands in the screenshot, I can not send an sms to another phone. I can view the messages and calls sent from the other party. What do you think could be the problem?

The response “ERROR” means you’ve probably made a syntax error in your command. Otherwise the error response would be: "+CMS ERROR: <err>"

You are obviously sending a carriage-return after your AT+CMGS="+90xxxxxx" line. Otherwise you would not get the “>” prompt.

What are you sending after the “Merhaba”? There must be no carriage-return there. You must use the single <ctrl-Z> character instead. This is ASCII character 26 decimal.

I send this command after AT + CMGS= "+ 90xxxxxx " line and the system itself puts "> ".
I don’t send anything after “Hello”. In my next attempt, I tried sending only “a” and sending “1” and got an error again.

To send “Hello”, you must send the six-character sequence:


There is no other way to do it.

Even in PDU-mode, the PDU has to be terminated with <ctrl-Z>.

I tried as you said and was able to send the message. Thank you so much.