UMTS voice call with EC25-E

I am trying to make a normal WCDMA voice call via the EC25-E using the ATD command. The behavior is not as expected.

I have registered on my UMTS network and see the connection is as expected using the COPS and CREG AT commands. When I enter the ATD command and trace the CC Setup message I see the Information Transfer Capability IE is 2, which according to the TS24.008 is requesting “3.1 kHz audio, ex PLMN”. I was expecting this to be 0 for speech. So it looks like the modem is requesting a multimedia bearer and not a standard speech bearer.

The setup I have is an EC25-E Mini PCIe using my company test sim and is attached to a SixFab Raspberry Pi HAT connected via USB to a Raspberry Pi.

What could cause this behavior and what do I need to do in order to get it to request the correct bearer type? Could this be a hardware configuration issue or are there settings I need to change?

Dear CellX,
Thanks for your inquiry in Quectel forum.
Could you tell me which method you use to check the information transfer capability ? And whether there have any impact on your application of the multimedia bearer ?
Could you help to fix the module on WCDMA mode,then make a call to check your concerned information? You can try the following AT command to fix it. Thanks!

I have my own cell and can trace the L3 messages direct as I have an in built CORE, or I can use wireshark to trace the L3 messages when I use a CORE that is located on the same LAN. The reason I want specifically speech is I want to test voice calling signalling programmatically. We currently do this using android phones via adb and an app running on android but want to use this modem instead.

I tried your suggestion of fixing the scan mode to WCDMA only, and I get the same behavior. The issue is not that the modem can’t see or camp on to my cell, but that it is requesting 3.1 kHz audio, ex PLMN and not speech when dialing.

Turns out I had a typo and hadn’t added a semicolon after the dialed number.

So your issue have resolved, right ? The reason is because you missed the semicolon when type ATD command, am i right? Thanks!

Yes all sorted, thanks.