Umts&lte evb (bg96)

I am new to quectel modules an development. I am currently trying to setup the BG96 evaluation board and verify BG950A module using the Qnavigator. The Qnavigator does not recognize the device. Before that, I followed all the kit setup and windows driver installation steps in provided in the eval kit user guide.

Upon connecting the Quectel eval board to the pc using the serial to usb connector, The module is not recognized as shown below.

After installing the drivers, there is no response as well. As per the eval kit user guide, I should see the following

I can only see Prolific USB-to-Serial Comm Port change when I connect the eval kit board (serial to USB)

There is no response on the QNavigator as well

Please let me know if I am missing some step. I can see the power LED and status LED ON (bright light) and I also see NET_STATUS LED binking ~ every 2s.

This is the response from Qnavigator. Seems like there is no communication at all

Are you using BG96 evaluation board with BG950A module?
if is, have you installed BG950A module series driver?
also , for BG95xA series modules need pull PON_TRIG to HIGH and then can communicate.


Thank you for your response.

  1. Yes, I am using BG96 evaluation board with BG950A module
  2. Are you referring to the Windows driver when u say BG950A module series driver?
    I have tried installing each of the following drivers separately and none of them seem to work
  •     Quectel_LTE_Windows_USB_Driver_V2.1.7
  •     Quectel_LTE&5G_Windows_USB_Driver_V2.1
  •     Quectel_LTE&5G_Windows_USB_Driver_V2.2.2  

Can you please provide additional info/link on which driver you are referring to?

  1. PON_TRIG is set as HIGH.

Also, there is no driver support for windows 11? we can never use the evaluation kit with windows 11?


Hi VenkatML,
I have sent BG950A driver to your email, and one more thing should be note:
UART_CLI need connect to you PC with usb cable,also PON_TRIG on a HIGH level is required.

Hi Linkin,

I truly appreciate you sharing additional info and also sharing the driver with me. But I already tried connecting the UART_CLI as well to my pc through the Micro USB cable and still couldn’t communicate with the LTE module through QNavigator. The CP210x driver was installed as well.

Also, all of what you mentioned now is little different from the Evaluation kit user guide. I do not see any of the Quectel AT ports or LTE module being recognized by my windows machine. If it is not too much trouble can you please share the user guide that you followed to get setup or share list of hardware setup and too/driver setup steps that you followed to get setup. By this way I can verify my steps and compare it with yours.

Please let me know


Hi VenkatML,

As image you shared, this port is not main uart, It’s UART_CLI port, for BG95xA series modules, currently only Main UART can send AT commands. refer to following picture.


Hi Linkin,

Yes, Main UART (marked COM1 on evaluation board) has always been connected as well. It shows up as Prolific USB-to-Serial Comm port

I still cannot communicate with the module using AT commands.

Please let me know.


Hi Linkin,

Just Fyi, I figured out the issue with the serial port communication. It was actually a power issue. It looks like powering the board through the Micro USB adapter is unstable for the modem. Hence, it is advisable to use a 5V through hole connector or USB connecto rfor stability of power. Now after using the 5V supply adapter, the connection seems more stable.

Thanks VenkatML,
Yes, we suggest to use power supply adapter to power. :slight_smile: