TLS connection, TCP, BC66


I am using BC66 with sw version
Revision: BC66NBR01A06

I want to connect to XMPP server using TCP connection. Following commands are used,

-After this command port openssucccessfully

AT+QISEND=1,200,<stream:stream from=‘Spark ID’ to=‘customer.url’ version=‘1.0’ xml:lang=‘en’ xmlns=‘jabber:client’ xmlns:stream=‘’>

  • I get “OK” as response


  • After this it fails and gives me ERROR or doesnt establish connection.

What could be wrong

Please upload your operation log and we will analyze it.

Thank for your response.

Please find the log attached (739 Bytes)

From this flag, I can tell that your terminal has been restarted or executed AT+CFUN=1.Then the terminal will re-register the network, the earlier TCP has been disconnected, you need to reconnect to the TCP server, so please check your program.

For some reason my hardware was sending that command, so i changed my hardware and here is the log for it. (517 Bytes)

Kindly check and let me know why is it getting knocked out

I don’t get it,Is your execution done by the MCU?
I recommend you manually enter AT Command through URAT and debug it.

Hello Herbert,

I am not using MCU, I am using Teraterm terminal and UART to communicate.
I copy and paste the commands from text file to teraterm.

Hello Herbert,

Does sw version BC66NBR01A06 support SSP AT commands ?

What does the SSP indicate? Or SSL?

I meant SSL.

Because when I try any SSL commands like AT+QSSLCFG=?, it gives me error

Please download: (2.9 MB)

Thank you for your response. Could you also send me procedure to be followed to flash BC66 using UART method and link to any tool which has to be used

please Upgrade through the UART port and set the baud rate to 921600
After clicking Start, if a reset occurs, you short-circuit the reset pin
qflash download link

Hello Herbert,

I tried to upgrade the Modem as it was listed in the document. But i get an error when i try to read sw files.

I have tried to change baud rate, downloaded again to check for corruption, followed instructions of naming folder where sw is stored. But, nothing worked.

I tried to run it as administrator as my PC is windows 10. Not sure if I am missing something

Please unpack your firmware upgrade package and try it out

Hello Herbert,

I unzipped and tried but it gives error,

Please use this tool to try again

Hello Herbert,

I tried to flash sw again using this new tool but I could not get it successfully.
Any other hint ?

Use URAT and set baud rate to 921600,try it again!