Tcp/udp Server ip and Server port setting

I’m new to Quectel and I started with MC60. Using Qnavigator, I’m testing TCP/UDP section. I set APN to how can I configure Server ip and Server port?


You could find relate document in


Best Regards,

Hi willie Yao,

I had already consulted, but without finding the solution…


AT+QIOPEN=”Protocol”,”IP Address”,”Port”

e.g.: AT+QIOPEN=“TCP”,“”,8007

Is this what you need?

I send this command but the log is “Fail to connect to server!”

You need ti check network registration status first.
And activate PDP context:
If you expect to get IP, you should be eble to connection a TCP server. The precondition is the port of the server is acceptable for incoming TCP connection.

I have this result from Qnavigator

… and this:

That’s test server is in China office. Sometimes it’s off-line. You testing procedure has no problem.

it is not clear to me how / where to find a tcp server and its port

If you just want to test TCP conenction. You can test any website like, port 443 or port 80


I had already tried with Google at port 80, but the results are always these. I can’t get a response in the “data received from remote” and then the connection closes. I just can’t understand where I’m wrong!

That’s expected because “hello” is not acceptable for google website. You need to send HTTP or SSL stack.

You can try following HTTPGET:
GET / HTTP/1.1
Host: quectel
Content-Type: /
Accept: /
Content-Length: 0

Please notes that there’s one more new line after the last line.

We have quectel EC25E LTE module connected to Raspberry pi by Sixfab Base HAT . We want to make TCP and UDP port forwarding to remotely access a server defined on Raspberry pi. We tried AT+QFWDSERVER but as we can understand it opens a port on modem only. It does not forward any packet to raspberry side. Could you please support the method to make the port forwarding. Does EC25E support port forwarding?