Settings for voice call on UMTS&LTE_EVB via headset

Hi experts!

I am trying to make a voice call via EC25-E module using UMTS&LTE_EVB
Alc5616 audiocodec is installed on the board

For the call I have set a headset and the alc5616 codec

Then I make a call to the specified phone number and answer it from the other side

When I say words to microphones from both sides then no sound is heared from any side: Head phones connected to the board keep silence.

Could you please tell me what other settings need to be done for me to hear the voice from both sides?

Thank you in advance

Dear sir,
Please check which codec type are you testing? The default codec is ALC5616. The default configuration is shown below.
[2020-06-18_19:05:54:225]+QDAI: 3,0,0,4,0,0,1,1

From your picture, 128K was configured, but the mdoule doesn’t support it. You can configure codec by AT+QDAI, please refer to AT commands manual.

Hi Aaron,

I have tried all other Clock frequencies but I still hear silence after the phone is picked up.

I also tried TLV320AIC3104 audio codec (AT+QDAI=5)
It also keeps silence/

Maybe you have some working AT-commands combination for testing the voice call?

Thank you/

Dear Kirill,
I copy my test log with ALC5616.
[2020-06-19_17:01:38:160]+QDAI: 3,0,0,4,0,0,1,1
[2020-06-19_17:01:52:397]+QDAI: 3,0,0,4,0,0,1,1
[2020-06-19_17:01:57:209]ATD10086; //I can hear the ringing through my headphones
[2020-06-19_17:02:24:416]+CLVL: 3

Hi Aaron,

Thank you for your reply.

I tried these settings but I still can’t hear the sound in my head phones.
I also tried to check the sound vie PCM out: I removed the sound codec from the board and set the PCM out with AT+QDAI=1,0,0,0,0

I performed the outgoing call from the board and accepted the incoming call on the external phone.
Then I said some words to both microphones during 7 seconds.
Then I finished the call.
I went to the folder Qnavigator_V1.6.9\AudioPath_20200612091236028
and found the file AudioOut.wav with zero length

I don’t have any other idea why the sound cannot be heared or recordered.

What are other possible reasons may affect the sound absense?

Thank you