SC20 module not responding in Host mode

We are using SC20 module at the slave mode it is able to detect in our PC .
We have the USB HUB where we are trying to communicate with the Sc20 Module From the USB Hub but we are not able to communicate with the Module.
the module is not enumerating things to the HUB.
whats the end point of the SC20 module for the usb resources
the USB hub part number is TUSB2046BVF

Dear Customrer:
Connect SC20 to PC through Hub, SC20 can be recognized normally, please check your Hub or hardware again, thank you.

No No We have a separate HUB IC TUSB2046BVF in our design we need that to be communicated with our SC20 module .
were SC20 needs to be master at that time and the HUB needs to be the slave

Hi, i’m facing the same issue trying to read an external device data, my build seems work properly and by dmesg 's log i can see that every connected device is recognized but i can’t see any /dev/tty* needed to start communication or to mount a mass storage device. I’ve tried adding some kernel modules concerned with OTG host role of the EVB but nothing changed.
Thanks in advance

with “lsusb”, can you see the VID and PID of the Hub?
Can you show the result of

cat /sys/kernel/debug/usb/devices

Did you use the USB_ID pin?

Here’s my /sys/kernel/debug/usb/devices content.

cat /sys/kernel/debug/usb/devices

T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480  MxCh= 1
B:  Alloc=  0/800 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev= 3.18
S:  Manufacturer=Linux 3.18.71-perf ehci_hcd
S:  Product=EHCI Host Controller
S:  SerialNumber=msm_hsusb_host
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=480  MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=058f ProdID=6387 Rev= 1.00
S:  Manufacturer=Generic
S:  Product=Mass Storage
S:  SerialNumber=B3F56455
C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=200mA
I:* If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=(none)
E:  Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms

With lsusb I can see both IDs, as you can see above, i have two devices, one for the HUB and one for the pendrive connected to it.

For input devices such as mouses i had no problems.

Do you mean the mass-storage driver cannot probe?

echo 1 > /sys/bus/usb/devices/1-1.1/bConfigurationValue
Maybe it works,
I guess you might see the kernel logs:

sb 1-1.1: rejected 1 configuration due to insufficient available bus power
[ 668.535424] usb 1-1.1: no configuration chosen from 1 choice

Input device such as mouses would not take too much power.

i’ve tried it but nothing happened.

that’s the output of dmesg after the hub and usb plugin:

[20686.722492] msm_otg 78d9000.usb: phy_reset: success
[20686.825596] msm_otg 78d9000.usb: USB exited from low power mode
[20686.827960] msm_otg 78d9000.usb: phy_reset: success
[20686.936554] msm_hsusb_host msm_hsusb_host: EHCI Host Controller
[20686.937163] msm_hsusb_host msm_hsusb_host: new USB bus registered, assigned bus number 1
[20686.943323] msm_hsusb_host msm_hsusb_host: irq 45, io mem 0x078d9000
[20686.955332] msm_hsusb_host msm_hsusb_host: USB 2.0 started, EHCI 1.00
[20686.957164] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[20686.957178] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[20686.957189] usb usb1: Product: EHCI Host Controller
[20686.957200] usb usb1: Manufacturer: Linux 3.18.71-perf ehci_hcd
[20686.957210] usb usb1: SerialNumber: msm_hsusb_host
[20686.958572] hub 1-0:1.0: USB hub found
[20686.958633] hub 1-0:1.0: 1 port detected
[20687.275330] usb 1-1: new high-speed USB device number 2 using msm_hsusb_host
[20687.433992] usb 1-1: New USB device found, idVendor=0781, idProduct=cfcb
[20687.434016] usb 1-1: New USB device strings: Mfr=3, Product=4, SerialNumber=2
[20687.434030] usb 1-1: Product: SDDR-B531
[20687.434044] usb 1-1: Manufacturer: SanDisk
[20687.434057] usb 1-1: SerialNumber: 1120200000006589

and this is my udevadm monitor log after i’ve plugged my otg hub:

KERNEL[20804.902918] add      /devices/soc/78d9000.usb/msm_hsusb_host/usbmon/usbmon1 (usbmon)
UDEV  [20804.911115] add      /devices/soc/78d9000.usb/msm_hsusb_host/usbmon/usbmon1 (usbmon)
KERNEL[20804.924239] add      /devices/soc/78d9000.usb/msm_hsusb_host/usb1 (usb)
KERNEL[20804.924717] add      /devices/soc/78d9000.usb/msm_hsusb_host/usb1/1-0:1.0 (usb)
UDEV  [20804.935981] add      /devices/soc/78d9000.usb/msm_hsusb_host/usb1 (usb)
UDEV  [20804.938754] add      /devices/soc/78d9000.usb/msm_hsusb_host/usb1/1-0:1.0 (usb)
KERNEL[20805.402710] add      /devices/soc/78d9000.usb/msm_hsusb_host/usb1/1-1 (usb)
KERNEL[20805.403875] add      /devices/soc/78d9000.usb/msm_hsusb_host/usb1/1-1/1-1:1.0 (usb)
UDEV  [20805.413198] add      /devices/soc/78d9000.usb/msm_hsusb_host/usb1/1-1 (usb)
UDEV  [20805.416409] add      /devices/soc/78d9000.usb/msm_hsusb_host/usb1/1-1/1-1:1.0 (usb)

The usb disk enumeration is done and seems everything is fine. But the usb storage driver is called.
Maybe the usb-stroage is not built-in.
can you see the log:

usbcore: registered new interface driver usb-storage

And whether the CONFIG_USB_STORAGE is added in the defconfig?