RM521F-GL able to connect to LTE only, but won't pass connection along to router?

I have an OpenWrt router that has an RM521F-GL connected to the WAN port via a M2 → RJ45 device.

The output of various AT commands are as follows:

AT

OK
AT+QCFG="USBNET"

+QCFG: "usbnet",2

OK
AT+QCFG="data_interface"

+QCFG: "data_interface",1,0

OK
AT+QCFG="pcie/mode"

+QCFG: "pcie/mode",1

OK
AT+QETH="eth_driver"

+QETH: "eth_driver","r8125",1
+QETH: "eth_driver","r8168",0

OK
AT+QMAPWAC?

+QMAPWAC: 1

OK
AT+CPIN?

+CPIN: READY

AT+C5GREG?

+C5GREG: 0,0

OK
 AT+CGDCONT?

+CGDCONT: 1,"IPV4V6","WAP.VODAFONE.CO.UK","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0,,,,,,,,,"",,,,0
+CGDCONT: 2,"IPV4V6","ims","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0,,,,,,,,,"",,,,0
+CGDCONT: 3,"IPV4V6","xcap","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0,,,,,,,,,"",,,,0
+CGDCONT: 4,"IPV4V6","sos","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,1,,,,,,,,,"",,,,0

OK
 AT+CGPADDR

+CGPADDR: 1,"10.178.28.143"
+CGPADDR: 2,"0.0.0.0","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0"
+CGPADDR: 3,"0.0.0.0","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0"
+CGPADDR: 4,"0.0.0.0","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0"

AT+QPING=1,"8.8.8.8"

OK

+QPING: 569
AT+COPS?

+COPS: 0,0,"vodafone UK",13

OK
AT+CPIN?

+CPIN: READY

OK
AT+CSQ

+CSQ: 17,99

OK
AT+QENG="servingcell"

+QENG: "servingcell","NOCONN","LTE","FDD",234,15,172812,153,2850,7,5,5,301F,-116,-18,-78,6,0,-,7

OK

If I restart the router and/or the modem, the router gets assigned the public IP as is shown above, I am able to run a speedtest for a few seconds before it disconnects and then I have no internet access at all.

I am using a Voxi (Vodafone UK MVNO) PAYG SIM.

Any ideas on how I can get a 5G connection and pass it through to my router?

You have a private IP.
Quick search gives me a different APN name - pp.vodafone.co.uk

AT+C5GREG? is for 5G SA mode only, while you potentially need NSA.
Check with AT+QNWPREFCFG="nr5g_disable_mode"

Here is the Voxi docs for APN. I swear I entered pp and not wap. Although looks like a user and pass is needed? I don’t see how to pass those along.

Either way, have updated with:
AT+CGDCONT=1,"IPV4V6","pp.vodafone.co.uk"

RE the IP, I see, you are correct. My mistake!

AT+QNWPREFCFG="nr5g_disable_mode"

+QNWPREFCFG: "nr5g_disable_mode",0

OK

Edit: After setting the APN above, and running AT+CFUN=1,1, it restarts - the router gets a connection for a few seconds and then the connection dies. It seems the IP assigned to the WAN port sticks - IPv4: 10.134.170.75/29, whereas before it would lose it.

Yes, the same page )

0 means both SA and NSA are available, so nothing to change there

Do you still see the same IP address in +CGPADDR response when “connection dies”?

I know this model is relatively new, so may be this is a software problem, see if Quectel can provide you with firmware update.

Yes, for example:

AT+CGPADDR

+CGPADDR: 1,"10.83.99.71"
+CGPADDR: 2,"0.0.0.0","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0"
+CGPADDR: 3,"0.0.0.0","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0"
+CGPADDR: 4,"0.0.0.0","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0"

And it seems to be the same just after a restart to when it loses connection.

I know this model is relatively new, so may be this is a software problem, see if Quectel can provide you with firmware update.

Understood. Do you think there’s anything needed for the APN regarding username/password as well?

Edit: I don’t think it’s anything to do with APN. Tried with a 3 SIM and APN set as three.co.uk - same issue, connection for about < 20 seconds after reboot of modem before it just fails again.

I would recommend ECM mode if you are using the RJ45 board by Ethernet. Seems to be pretty stable. Any other usbnet mode you need to make sure AT+QMAPWAC=1 or it won’t auto connect the radio to the rest of the interfaces. In ECM this just happens automatically.

AT+QCFG=“usbnet”,1
then reboot

If you used the AT+QETH=“RGMII” command… don’t use that.

I’m still in the process of confirming it but I think that’s what was causing my Ethernet port on the RJ45 board to stop responding in certain scenarios.
Run AT+QETH=“RGMII” to check it. If it says ENABLE run AT+QETH=“RGMII”,“DISABLE”,1
then reboot

For IP passthrough there’s 3 levels of IPPT

  1. DMZ method (not a true IP passthrough)
    Set the modems DHCP to only hand out one IP address with AT+QMAP=“LAN”,192.168.225.2
    If that errors on you then you don’t have that command on that firmware revision so use this to define the whole dhcp range and gateway AT+QMAP=“LANIP”,192.168.225.2,192.168.225.2,192.168.225.1,1
    Then, set that IP as the DMZ with

AT+QMAP=“DMZ”,1,4,192.168.225.2

  1. Actual IPPT
    AT+QMAP=“MPDN_rule”,0,1,0,1,1,“FF:FF:FF:FF:FF:FF”
    If you want the DNS from the provider to pass through as well: AT+QMAP=“DHCPV4DNS”,“disable”
    You should still be able to access 192.168.225.1 if you have a web server running on the modem still.

  2. I haven’t messed too much with this yet because it disables local access to the gateway address (192.168.225.1) but it’s the final step to a true IPPT mode.
    AT+QMAP=“IPPT_NAT”,0

First time I ran that I went…oh crap I can’t access my admin page any more! :rofl:
(I have a webserver running on the modem serving a management page that accepts AT commands and shows signal stats)

P.S. If you run AT+QMAP=“WWAN” it’ll show you both the IPV4 and IPV6 address assigned from the carrier.

1 Like

That did it! Until I tried setting it to 5G only, and now I can’t get a connection back again to the router.

Setting AT+QNWPREFCFG="mode_pref",NR5G was what I did. It assigned the router IP of IPv4: 192.168.225.105/22 whereas before it was in the 10.x.x.x range when using LTE. Running AT+QMAP="WWAN" results in no assigned IPs.

Switching back to AT+QNWPREFCFG="mode_pref",LTE:NR5G now results in no IP being assigned to the router at all, and I haven’t the foggiest why? Output of commands as they currently stand:

AT+QETH="RGMII"

+QETH: "RGMII","DISABLE",1,-1
+QETH: "RGMII",0,1
+QETH: "RGMII",0,2
+QETH: "RGMII",0,3 
+QETH: "RGMII",0,4

AT+QMAP="MPDN_rule"

+QMAP: "MPDN_rule",0,1,0,1,1
+QMAP: "MPDN_rule",1,0,0,0,0
+QMAP: "MPDN_rule",2,0,0,0,0
+QMAP: "MPDN_rule",3,0,0,0,0

AT+QMAP="IPPT_NAT"

+QMAP: "IPPT_NAT",0

AT+QMAP="WWAN"

+QMAP: "WWAN",1,1,"IPV4","10.98.209.63"
+QMAP: "WWAN",0,1,"IPV6","0:0:0:0:0:0:0:0"

So, the carrier seems to be assigning the IP, but WAN doesn’t get anything on the router.

I did a power cycle, and it seems to give the router IP 10.98.220.55/28 for 10-30 seconds before dropping it again. Edit: Actually seems to be a random 10.x.x.x address each time it reconnects.

No idea what’s going on.

Edit: OK, so another power cycle, USB and RJ45 both connected and it seems to keep the connection stable!

So, I try switching back to the Voxi SIM - an IP gets assigned 10.37.159.79. This is what AT+QMAP="WWAN" outputs and it seems to get passed to the router’s WAN port. Immediately after a power cycle, there is internet access for about…20 seconds before it dies.

So, seems like an issue with the network in this case? Maybe APN issue? Does user + pass need to be passed alongside somehow?

First time I ran that I went…oh crap I can’t access my admin page any more! :rofl:

I’ve seen your GitHub page! Very useful info, thanks.

Edit 2: I’ve decided to just keep using 3 for the moment, as at least the connection works. It’s not the best network though.

So, basically:

  • Can’t seem to get 5G on any network.
  • Can’t seem to get IPv6
  • Can’t seem to keep connection to Vodafone UK.