RM521F Firmware

Hello mods,

Can I please get RM521F-GLEA firmware? I accidentally delete something via adb mode and now no internet. Please provide any firmware.

Thank you.

@JT_JT I do not have a copy of the RM521 firmware, but I do run that modem. Are you still able to run AT+ commands? If so you might just need to set QMAPWAC back to 1:

To test:
(get current status of auto connect, 0=disabled 1=enabled)

(enable auto connect internet for ethernet)

Then run a reboot:

Let me know if this helps

Also, check out this thread it might be related (again if you can run AT+ commands)
*If you’re running a windows machine check ports via USB connection and then putty serial to that com port and you should be able to run AT+ commands again other wise netcat (nc) commands on Mac or Linux

The serial connection is not forgiving, and if you make a typo just CTRL+C or hit enter and start over, also if you use copy and paste a lot of times the double quote is wrong and curly if you will… So best to type out the commands.

My unit worked via m.2 to eth BEFORE. I was messing around with service files and it stopped working. DNS not working. I restored the service files but it did nothelp.

Edit: restored but it did not help.

@JT_JT How were you able to activate the adb mode on the RM521F-GL?
I have not been able to accomplish this.

Revision: RM521FGLEAR05A02M4G



+QCFG: “rrc”,(0-5)
+QCFG: “hsdpacat”,(6,8,10-24)
+QCFG: “hsupacat”,(5,6)
+QCFG: “pdp/duplicatechk”,(0,1)
+QCFG: “risignaltype”,(“respective”,“physical”)
+QCFG: “lte/bandprior”,(1-43),(1-43),(1-43),(1-43),(1-43)
+QCFG: “volte_disable”,(0,1)
+QCFG: “diversity/config”,(4,6),(1-4),(0)
+QCFG: “div_test_mode”,(0,1)
+QCFG: “usbspeed”,(“20”,“311”,“312”)
+QCFG: “data_interface”,(0,1),(0,1)
+QCFG: “pcie/mode”,(0,1)
+QCFG: “wifi/model”,(“fc64e”,“fc06e”,“fc06e-33”,“fc60e”,“fc08e”)
+QCFG: “pcie_mbim”,(0,1)
+QCFG: “sms_control”,(0,1),(0,1)
+QCFG: “call_control”,(0,1),(0,1)
+QCFG: “usb/maxpower”,(0-900)
+QCFG: “efratctl”,(0,1)
+QCFG: “gatewayset”,(0,1)[,]
+QCFG: “netmaskset”,(0,1)[,]
+QCFG: “clat”,(0,1),(0,1),,(0,32,40,48,56,64,96),,(0,1),(0,1,2,4,8),(0,1),(0,1),(0,1,2),(0,1,2)
+QCFG: “usage/apmem”
+QCFG: “enable_gea1”[,(0,1)]
+QCFG: “dhcppktfltr”,(0,1)
+QCFG: “uart”,(0,1),(0,1)
+QCFG: “mmwave”,ant_chip,ant_type,panel_value,hwid_value
+QCFG: “rollback”,(0,1)

Your quote is note correct. Manually type it in. AT+QCFG=“usbcfg”

1 Like

Thanks for the assistance! I was copying and pasting into Putty previously and receiving an error. When I manually typed in the command into Putty, it worked.

Dear @JT_JT @m1xmstr
If you want to get the latest firmware, please contact with your provider firstly, thanks for your understanding.

Who the AliExpress seller? If there is a new firmware why not share it?

Yes, contact them first. Generally they will share it, if they are authorized by Quectel.

Maybe because you bought an “Engineering Sample” and those are still under development.

What seller you buy it from?

I’m from now on going to buy from DigiKey, or my local FAE. It’s not worth the hassle buying from Alibaba or Aliexpress and later coming here to beg for firmware. The last unit I bought came in part with a GliNet router.

Good input @Alpha – I too would normally go official but couldn’t find the 521 anywhere. I have a RM520 and really like the fact I can find firmware and a lot of resources on GitHub – I would just really like this being a the official Quectel forums and all that they would post the firmware here.

As far as an Engineering Sample or not I have mixed thoughts on this. I have ran ES on both 4G, 5G and even Intel Xeon for years usually without issues – and usually I’d day 80% seem to perform better than the real. :person_shrugging:

I just enjoy this hobby and look forward to how well this RM521 should perform in the future.