Rm520n-glap adb

Trying to get ADB shell to my RM520N-GLAP and am hitting an issue. Got the modem unlocked, and it is detected, but in a constant “offline” status. Is it a driver issue? It picked up default WinUSB driver and Windows 10 won’t let me update it to anything else as “Windows has determined that the best driver for this device is already installed”

Revision: RM520NGLAPR01A03M4G

+QADBKEY: 25816482


+QCFG: “usbcfg”,0x2C7C,0x0801,1,1,1,1,1,1,1

adb devices
List of devices attached
90abcdef offline

It will take effect after reboot.

Please also check the AT command


Yes, I’ve tried both “AT+CFUN=1,1” and hardware reboot.

+QCFG: “usbnet”,2

+QCFG: “data_interface”,1,0

I’ve tried “AT+QCFG=“data_interface”,1,1” but it did not change anything.

By the way, this is the PCIe only AP variant. Is there maybe a separate procedure for unlocking the ADB that is exposed over PCIe? Or maybe a separate “usbcfg” command, as the PID returned by “usbcfg” (0x0801) doesn’t match the PID of UDE Client ADB Device (0x0802)?

What’s the firmware version?

Please don’t change the PID of the device.
It seems that you have changed the USB PID.

Mar 24 2022 03:18:54
Authors: Quectel


I never changed the PID. It was mismatched like that out of the box. “usbcfg” even now still returns 0x0801 even though the UDE Client ADB Device is enumerating with 0x0802. What PID should I have?

Is there a way to contact you directly? I have to wait 45 minutes for each reply…

It should only be 0x0801.
Do you have a Linux PC? Could you try it on Ubuntu?

RM520NGLAP R01A03M4G_01.001.01.001

OK. yes it is PCIe only. And it do not support USB. You cannot login with adb.

The ADB device that is already enumerated via the USB Device Emulation (UDE) over PCIe is good enough for me. I don’t need nor am I trying to use the USB one. The PCIe ADB Device already shows up in “adb devices”. The problem I am having is it is always shown as “offline” in adb. It seems as if the approval/unlock didn’t go through.

Sorry I have never seen any try the adb over PCIe.
If you must login in the modem it is better to try the AT version but not the PCIe only version.
Otherwise you can login in the modem via debug uart.

How do I do that? Does the debug UART provide root shell?

You can login with the debug uart.


Thank you. This only being available on testpoints is less than ideal of course, but hopefully I’ll just be able to unlock the PCIe ADB via it and use that as planned moving forward.

Oh, last question before I forget, the logic level on the debug uart is 1v8, correct?

Yes. 1.8V.
Normally Quectel will not provide the solution for non VIP customer to login the STD modem

Got it connected, but it is password protected. Can you please provide root password for the following module:

QTI Linux reference nogplv3 distro targeting performance builds. r00223.1 sdxlemur ttyMSM0
 quectel-v : v1.0
 quectel-ID : 25816482

username: root

1 Like

Got ADB working over PCIe. all you need is AT+QPCIE="adb",1
I am assuming it needs ADB to be unlocked first with +QADBKEY but I have no way to test it as mine is already unlocked with +QADBKEY.
Removing /data/.adb_enable has no effect on it though, but I suspect that is simply not enough to re-lock ADB.