RM520N-GL "SIM Not Inserted" Error - Australia

Hi guys,

I am in the process of making a 5G bonding router for livestreaming and plan on using 3 Quectel 5G modules with a Raspberry Pi. I am trying to get 3 RM520N-GL modules to work as USB 5G modems but I’m having trouble getting them to work. First up I tried getting them to work through my GL iNet Slate AX with auto setup, but it gave me a SIM missing error. I’ve since tried using QNavigator and when I connect it gives me SIM missing error.

[2023-06-30 17:14:23:914_R:] AT+CPIN?
[2023-06-30 17:14:23:914_R:] +CME ERROR: SIM not inserted

In total I have 3 RM520N-GL modules using 3 of the GL iNet M.2 5G development boards. I have also purchased another M.2 to USB modem adapter and tried it but I am having the same issues. I have tried 3 different SIM cards, one from Telstra, one from Optus, one from Vodafone all with the same results. All the SIM cards are activated and when put in my phone, all work fine and get data instantly. I have tried regular means of rebooting, making sure pin contacts on the SIM are making contact etc.

Is this something to do with me being located in Australia and using Australian SIM cards? Should that even make a difference? Are there any settings I can try to change?

Thanks in advance


What does AT+QUIMSLOT? return?




Thankyou very much for the help. SIM slot by default was set to 2 on all of the modems. Setting SIM slot to 1 has made it recognize the SIM. Thanks!

For your information ROOter “firmware” is available for installation on a wide range of Raspberry Pi models.


It includes support for Quectels like the RM5x0N series.