RM520N-GL rrc setup fails

We have RM520N-GL modem with RM520NGLAAR01A07M4G firmware.

In some modes of operation our BS, modem can see the cell, but didn’t attach:
+QENG: “servingcell”,“LIMSRV”,“NR5G-SA”,“TDD”,001,01,000000013,157,1,647232,78,3,-79,-11,25,1,51

After analyzing the QXDM logs, our protocol team said:
RRC setup fails because of non codebook SRS configuration”.

All other Qualcomm modems (but with x55 chipset) works fine with this mode of operation.
Maybe you have newest firmware, we can check it.

Is it possible to fix this bug. If you need QXDM file from modem, i can provide it.


After looking to AT+QCFG=“rrc” command, i found that default RRC is R9.
Our protocol team said, in this specific mode we use RRC R15.

Is it possible to check this ussie?



I also have LIMSRV on RM520N-GL but with LTE network.
Could you please share how to log collect to catch issue during RRC registration in the network?
If it is possible in router part…
May be you can provide recommendation how to try to solve the issue…


Hi Anton,

If you have LTE network, it is different case. If you have commercial network, it may be better return to auto MBN selection.

I don’t think it router part, but try to check if APN set correctly on modem with command:

In the past we have router, that transfer “IPV4V6” instead of “IP”, and this also was a problem.

We are developing our 5G SA BS, so we use many different modes of operations, that currently new at all, and may be not present in modem firmware.
The LIMSRV may have very many reasons, so my case isn’t yours at all.
For my case i need Quectel team to look on my QXDM logs, and help me with this.

To collect QXDM logs, you need Quectel QLog tool, or dedicated debug USB port from the modem.
If you don’t have dedicated USB port, you need QLog compiled and installed on router. Also, Quectel tool for windows, to collect the QXDM logs.
And for log analyze, you need QXDM tool.

Thanks, I will try to solve my issue…

Hi Dmitry,

Did you fix the LIMSRV issue?


Hi Andrew,
“LIMSRV” isn’t issue, it modem state. Why modem stay in that state - it may be million reasons, and need investigate each one.
Do you try to connect to commercial network?
Is APN set correctly?
What is you FW version?
What is your location? (some modems and version have limitation to connect)
Try to manually setup module (with at-commands, and not with some applications) and try manually register to network.

BTW, in my case, we have private network, and this mode still not solved. But this is Qualcomm issue, and not Quectel. We try to solve it