RM520N-GL M.2 modem has IMEI number not recognized by either Verizon or AT&T

I spent a considerable amount of time trying to activate data-only service with Verizon and AT&T in the US. I entered the IMEI number printed on the M.2 module with the AT&T’s online ordering tool, and it was shown to be invalid. I subsequently spoke with a Verizon rep, being told the same thing. The M.2 modem is mounted on a “5G Hat” for a Raspberry Pi 4B, sold by Waveshare. The 5G Hat has two SIM slots, which in theory should allow me to install SIM cards for both AT&T and Verizon. I tried to convince Verizon to just sell me a SIM card, that the module should work since it has Qualcomm silicon, though they wouldn’t do that. One thought I had was to buy a hotspot loaded with a SIM card, just to pull the SIM card and try it on the 5G Hat, though I’ve seen postings by others who seem to be having IMEI issues with the RM520N-GL. I’m hoping I’m not the first person trying to use this module on Verizon and AT&T services!

Dera @bhinman
Actually, this module had passed the certificate of AT&T and Verizon.

You are likely speaking of technical qualifications, correct? Can you please send a copy of the Verizon and AT&T certifications?

Are you certain that Quectel has registered the TAC/IMEI data through the GSMA?




Verizon rep says this is NOT a supported IMEI. What carrier is supporting it?

I just went through a similar situation trying to add a line to my VZW business account. The online VZW BYOD web page was rejecting IMEI numbers that I input and knew were good, a search of the IMEI numbers on IMEI dot info showed the IMEI numbers as a good values (clean). What I ended up doing was generating an IMEI value on the IMEI info page for a Apple iPad 2022 hardware profile so I could add a unlimited tablet data plan to my VZW account. Even then the BYOD web page said it could not be activated, call customer service, blah, blah. I used the VZW CSR chat, and gave the CSR the same generated IMEI number for the Apple ipad HW profile, along with a 6 dollar new VZW SIM number from AMZ, the rep plugged everything in, triggered an email for me to confirm the order, and SIM was activated. I took the SIM and inserted into my 5G modem, set the IMEI number I had given to VZW rep via AT command, few seconds later I was connected to VZW, speed test under tablet profile unlimited plan about a mile or so from the tower gave ~75mpbs DL and ~20mbps UL. I hope this helps! :slight_smile:
Make sure to set TTL to 88 to avoid hotspot issue. I’m just getting started with might so you may have to Google / research a different TTL value if you find 88 isn’t working for you and you get throttled. I don’t think VZW will knowingly allow cellular modem that not a VZW sourced product. Phones, yes, mode/router/gateway I think not as I asked the VZW business rep when I was ordering service that I wanted to BMOD for business internet and was told they don’t allow that, you have to get their modem/gateway units.

Thank you! This is very helpful. When you said you generated “an IMEI value on the IMEI info page for an Apple iPad 2022 hardware profile,” are you referring to a Verizon database, or the GSMA database? And was your device actually an iPad, or you just said that to get through the system?

It has occurred to me that perhaps I’m supposed to be entering the device information in the GSMA database, as the end device isn’t a Quectel M.2 modem, but rather whatever it’s plugged into as a finished product. Perhaps Quectel (and Simcom) are generating valid IMEI numbers, but never populating the device description? In which case, loading the description may allow activation with Verizon and AT&T, assuming they allow BYOD.

Which brings me back to the question of the GSMA database. What authorization is required to make edits?

Thanks again,


Hi Brian,

Check your personal chat.
In a few minutes.



Has anybody figured this out? Verizon is still saying this modem is not supported.

My imei in my country Ph blocked access to net after months of using RM520. Solution was just replace imei to regain access. i don’t know if its legal in your country.

Actually, this module had passed the certificate of AT&T and Verizon.”

While you might claim that, the fact of the matter is the issue STIL persists. Just got my Lenovo ThinkPad X1 Carbon in (July 15, 2024) with said RM520N-GL adapter and its MEI number is NOT recognized by Verizon. I tried it through Verizon’s stie, and through Verizon’s tech support. The MEI number simply won’t work. Period.

Instead of fluffing off customers, my question is how can we resolve this issue???


Dear @Andrew_Minton
For Lenovo ThinkPad X1 Carbon, you should to contact with Lenovo. They will test this and module is just a component of notebook.

Is the module inserted in notebook when you buy it? Or you buy it and insert in it?

The module was a selected upgrade for the Carbon X1 (12th Gen), so yeah, it came installed in the notebook.

And for the record I called Lenovo tech (after speaking with Verizon), but they were more interested in blaming Verizon (claiming Verizon was doing something wrong, which they weren’t). Verizon was busy blaming Lenovo as they, and manual input to the website says the IMEI key is invalid - yes, I checked the IMEI number numerous times, the number is correct. It’s simply not recognized by Verizon.

BTW, the Lenovo tech person I spoke to said the ONLY thing they could do is have the card replaced but I’d have to send it in. They claim they don’t deal with IME issues (I think that’s bull, but…). At this moment, I’m not willing to send it out for about a month to fix what shouldn’t have been a problem to begin with… an unrecognized IMEI number.

If I’m going to have to go through all that, I may as well return the laptop. For now, I just use my phone’s mobile hotspot, and that works well. I’d just like to have not wasted $150+ on a feature that doesn’t work.

I don’t understand why Lenovo is selling modules that clearly have IMEI recognition issues. Or why Quectel can’t solve this themselves. It is your module.


Dear @Andrew_Minton
Please share the IMEI number.