RM520N-GL is used as eth1 with openwrt via IPPT mode, devices connected to the openwrt system cannot access ipv6 resources correctly

I have now assembled a device which consists of two parts, one is the rm520ngl module and the other is the mt7981 which constitutes the wireless router system, the connection between the module and the wireless router is made internally via 2.5G Phy and the ippt mode used, both wan and wan6 are correctly obtained in the openwrt system and ipv6 address can correctly assign ipv6 to other devices connected to openwrt after setting openwrt to relay mode, but the other devices can’t access the ipv6 network properly, the openwrt device itself can access the ipv6 resources, it looks like some settings in the module are preventing other devices from passing through it, please help me

This question is better suited for OpenWrt forum.

I’m sure this has nothing to do with openwrt, v6 works fine when using wired internet access

woo dd dalao haoshuai

Dear @Icey
Actually, I didn’t get your point. One device worked, the other device didn’t worked, right? Use the same connection?
Please share your current firmware.

I’ve solved the problem, tks a lot :-)

@Icey Could you share how you fixed this? I’m running in to the same problem and haven’t found a solution.

Enable the module’s adb and then manually write ipv6 routes in the module’s firewall via adb, but I think this method is dirty-hack

@Icey Fascinating!! What did you do exactly to write the IPV6 routes? Perhaps I can make a script that automatically does this at boot utilizing systemd!

In normal cases, if ipv6 dial-up is enabled, OpenWrt automatically obtains the ipv6 address.
Check the ipv6 accept_ra configuration of OpenWrt.