RM520N-GL IPPT (IP Passthrough)

I’ve been trying to put my RM520N-GL in IPPT, but the AT commands may have been wrong. I’ve recently received the latest AT command manual and have succeeded in IPPT… My ethernet interface now receives the public IP address from my Cellular Provider.

a) at+qmap=“mpdn_rule”,0,1,0,4,1,“FF:FF:FF:FF:FF:FF” successfully put my modem in IPPT. The numeral ‘4’ in the above commands enables IPPT to all interfaces (ie, ethernet and usb).

b) I’m not sure now how to disable this! The command:

at+qmap=“mpdn_rule”,0,1,0,0,1,“FF:FF:FF:FF:FF:FF” to disable IPPT results with an error!

Thoughts appreciated please!

OK, so I can disable the rule with at+qmap=“mpdn_rule”,0 and running the query command at+qmap=“mpdn_rule” shows it is disabled…

And I can also re-enable the IPPT rule with the above command - at+qmap=“mpdn_rule”,0,1,0,4,1,“FF:FF:FF:FF:FF:FF”

BUT the IPPT does not pass through the public IP address now!
The DCHP address is allocated to any ethernet interface (the USB RNDIS interface has always got the public address).

Any further thoughts about getting IPPT to work please?

EDIT - obviously what I’m trying to do is to avoid double-NAT from the modem to an external router…

I don’t think you should expect a public IPv4 address to be available on the modem and/or on the attached host.
With IPPT working both modem and host should report 10.x or 100.x address assigned by the carrier.

BTW, here is a success story with IPPT: Can't place RM520 in IP Passthrough (IPPT) mode - #4 by sirozha

I’m not too worried about a proper public IP - but I still get the NAT IP of (eg) 192.168.10.x (I’ve changed the IP range from the Quectel default 192.168.225.x to 192.168.10.x).

I don’t get a 10.x or 100.x IP address… I just want to disable NAT from the module and avoid double NAT…

What do you have in at+qmap=IPPT_NAT ?
I don’t see “4” as allowed value for IPPT_mode in the manual I have. Assuming that Ethernet connection is in place I would use “1” for IPPT_mode and even set the specific MAC. Power toggle is a must :wink:

1,2,3,4,5 are in the latest manual I have from Quectel…


My problem now is that I can enable and disable a rule but it always now still does NAT over the range 192.168.10.x (I’ve changed from the default 192.168.225.x)…

I do have adb access to the full module file system so I wonder if I can change anything directly to stop NAT?

I don’t particularly care about a true public IP - but I do want to stop the NAT and avoid double-NAT!

What do you see in response to at+qmap=IPPT_NAT ?

Hi, I’ve tried setting ippt_nat = 0 and that has no effect (the result is 0, to answer your question, but NAT still works!)…

Thank you for checking. You’re checking on Ethernet, not USB - right?
Can you check:


a) Yes I am definitely on Ethernet! When I use USB I do get a non-NAT ip address
I can power the module with 12V and NOT use USB for power…

b) AT+QETH=“ipptmac”
+QETH: “ipptmac”,00:e0:4c:68:01:c8

(This MAC address above is the MAC of an ethernet interface I am connecting to the module - you can specify a MAC address to receive the first IPPT ip address - but this does not work either!) I used the command below to set this MAC address:

AT+QETH=“ipptmac”,a1:b2:c3:d4:e5:f6 //Set the current MAC address of IP Passthrough mode.

c) AT+QETH=“rgmii”
+QETH: “RGMII”,1,1
+QETH: “RGMII”,0,2
+QETH: “RGMII”,0,3
+QETH: “RGMII”,0,4

d) Regarding RGMII, I’ve also tried to setup IPPT with RGMII and it still donesn’t work!


May you pls send me the AT commands manual which you have?

Here is the latest manual that I have…
Quectel_RG520N&RG525F&RG5x0F&RM5x0N_Series_AT_Commands_Manual_V1.0.0_Preliminary_20230731.pdf (2.1 MB)