RM502Q-AE not working with TMO PLMN

Hello,

I am trying to connect to NSA network with RM502Q-AE which should support US bands, I tried initially with Verizon but I quickly noticed that it was not working properly. I tried to change for TMO 310:200 PLMN but I can´t connect to NR, only LTE is working. I verified with working phone that the sim card is working properly.

My question is, where the problem could be with the modem? Do you have any suggestions what commands I should run to debug the error?

Thanks in advance.

Dear Sir,
Please operate these AT commands and send the returns to us, thanks!
ATI
AT+CGATT?
AT+COPS?
AT+QENG=“SERVINGCELL”
AT+QNWPREFCFG= “mode_pref”
AT+QNWPREFCFG=“nr5g_disable_mode”
AT+QNWPREFCFG=“rat_acq_order”

Thanks for quick answer, here are the outputs:

ATI
Quectel
RM502Q-AE
Revision: RM502QAEAAR11A04M4G

OK
AT+CGATT?
+CGATT: 1

OK
AT+COPS?
+COPS: 0,0,“T-Mobile NSN”,7

OK
AT+QNWPREFCFG= “mode_pref”
+QNWPREFCFG: “mode_pref”,AUTO

OK
AT+QNWPREFCFG=“nr5g_disable_mode”
+QNWPREFCFG: “nr5g_disable_mode”,0

OK
AT+QNWPREFCFG=“rat_acq_order”
+QNWPREFCFG: “rat_order_pref”,NR5G:LTE:WCDMA

AT+QENG=“servingcell”
+QENG: “servingcell”,“NOCONN”,“LTE”,“TDD”,310,200,5E9D01,473,40990,41,5,5,9A,-79,-5,-53,24,15,-,-
OK

Dear Sir,
Do your simcard support nr5G? do your testing environment have nr5G signal?
Can you try to fix the module into nr5G mode by sending AT+QNWPREFCFG= “mode_pref”,NR5G
Thanks!

Try setting the modem to 5G only via the command provided by Peter.Zhu-Q
AT+QNWPREFCFG= “mode_pref”,NR5G

If the 5G signal level is lower than 4G-LTE at your location, the modem will automatically switch to 4G-LTE.
5G may work in your test phone, but every device picks up the signal differently and have different prioritization settings. Double check all the antenna connections to your modem, because a bad connection could also cause the 5G signal to fail.

After forcing the modem to 5G only, but still not getting a 5G signal/connection, it may be caused by the following:

  1. Lack of 5G signal at your location
  2. Bad antenna connection
  3. Carrier may not recognize your modem’s imei as a valid 5G device, therefore the tower falls back to 4G-LTE.