RM502Q-AE A04 firmware

The RM502Q-AE I received directly from Quectel in November 2021 arrived with firmware version RM502QAEAAR11A04M4G_01.002.01.002 I downgraded the firmware to an earlier to release to troubleshoot a problem but it didn’t resolve the issue.

Can you provide a link to firmware version RM502QAEAAR11A04M4G_01.002.01.002 or later so I can restore the version the module was shipped with.

Dear Sir,
Here you are~

Hello all, sorry to but into your convo, but would either of you be be kind enough to post a link to the A02 firmware? I’d very much appreciate it. Thanks in advance.

Dear Tom,
It is okay, but I wonder why you are ask for A02 firmware, because I have put the latest firmware into the above link.Thanks!

The firmware linked above is working very well. Even the qnwlock command is working which other people report problems with A04.

Good to hear that, thanks!

Sorry for late reply, I have a RM502q-ae, running in a WBT1608 router that won’t connect to 5g at all. Seems like it’s connected to the network, but absolutely refuses to pass data. Have a T mobile data sim that works in another device, but not in the Quectel. I have read through countless forums and groups trying all kinds of changes to settings, but the Quectel just refuses to pass data. I thought about trying different firmware, but I’ve given up at this point and am going to look into another setup.
Thanks anyway for your reply.

Have you tried the TTL settings? I had a couple of modems that wouldn’t pass through without that!..65, or 66

Thanks for responding and sorry again for late reply.
Yes, I have tried changing the TTL, but it did not help.
The main issue is that my modem only seems to work in either LTE or SA mode.
I need it to work in NSA mode, but it seems to be either broken or disabled.
I have selected the 4G-5G shared mode on the router, but it only connects to LTE. Seems like it just cannot aggregate LTE and 5G bands like it needs to.
Any thoughts?