RM500Q Linux Drivers

Hello,

Would it be possible to get the the latest Linux drivers for the RM500Q-GL chip. Compatibility with Ubuntu 18 or 20 is preferable.

Thanks
William

QConnectManager_Linux_V1.6.1.zip (221.8 KB) Quectel_Linux&Android_QMI_WWAN_Driver_V1.2.1.zip (26.7 KB) Quectel_LTE&5G_Linux_USB_Driver_User_Guide_V2.0.pdf (564.5 KB)

Here you are, please download, thanks!

Hi Peter, thanks for those drivers they appear to be working, unfortunately I have run into an issue when trying to issue AT commands to the module.

I would like to pull serving cell information on a 2-3 second interval unfortunately when the device is used under Ubuntu the AT command communication is very unreliable. I was initially pulling the data using PySerial a package within Python, then I tried Bash, these applications pulled data but it was inconsistent sometimes it would retrieve the data but more often that not it would fail.

At the moment as a sanity check I am using the following command busybox microcom /dev/ttyUSB2. I then run this command at+cpin?;+csq;+cops?;+qeng=“servingcell”;+qeng=“neighbourcell”. This works the first 3 to 4 times but then it stops responding. I have tried a baud rate of 9600 and 115200 but it doesn’t seem to make a difference.

These same commands run reliably under Windows so maybe I might be missing something here, any help would be greatly appreciated.

Thanks
William

Dear Sir,
Do you use ModemManager? please stop it using below commands, then make a comparison test using quectel-CM(QConnectManager) I have sent before.Thanks!
systemctl stop ModemManager
systemctl disable ModemManager

By the way,in order to better support you, please provide below information to us, thanks!
*Company name and located Country:

  • Project name (so we can refer to it in the future):

  • Application type:

  • Estimated Annual Units (for series production):

  • Project timeline:

  • Current status:

  • From which distributor do you buy Quectel modules & EVB kits?

  • Do you have EVB kit for this application?

Hi Peter,

I sent you a direct message in relation to this.

Thanks

Hi Peter,
When I run the make install command for the QMI WWAN driver, I got the error: ‘WWAN_PORT_QMI’ undeclared, as shown in the attached screenshot.

.

Since I use kernel 5.13.0-37-generic, the error occurs at line 1843 in qmi_wwan_q.c because of undeclared parameter WWAN_PORT_QMI

	/* register subdriver */
#if (LINUX_VERSION_CODE > KERNEL_VERSION( 5,12,0 )) //cac6fb015f719104e60b1c68c15ca5b734f57b9c
	subdriver = usb_cdc_wdm_register(info->control, &dev->status->desc,
					 4096, WWAN_PORT_QMI, &qmi_wwan_cdc_wdm_manage_power);
#else
	subdriver = usb_cdc_wdm_register(info->control, &dev->status->desc,
					 4096, &qmi_wwan_cdc_wdm_manage_power);

#endif

Your help is highly appreciated :slight_smile:

Please modify this sentence to if (LINUX_VERSION_CODE < KERNEL_VERSION( 5,12,0 )).

1 Like

Thanks Isaac for the help!
Unfortunately, the suggested change did not work for my other Linux machine running kernel 5.4.0-97-generic, as shown below.

Please modify this sentence to if (LINUX_VERSION_CODE >= KERNEL_VERSION( 5,14,0 )).

1 Like

Other content does not need to be modified.

1 Like

can you tell me, where can I find the source codes for GobiNet driver?
I followed the instruction given in the pdf and im pretty new to this topic.

1 Like

Salam Abdul Aziz,
You need to open a ticket here https://e-service.quectel.com/en/support/login, to get access to the drivers.