RM500Q-GL not enumerated



Revision: RM500QGLABR11A05M4G


2021newest In-tel Core Tiger Lake Core Board 11th Processor I5-1135g7 Onboard 8gb Ram - Buy In-tel Core Tiger Lake Core Board 11th Processor,Onboard 8gb Ram I5-1135g7,I210 Lan Card 1*intel I219-lm Lan Card Product on Alibaba.com

The Problem

The RM500Q-GL is not detected in the m.2 B-key slot (neither USB nor PCIe mode). In the same m.2 B-key slot, I’ve tried plugging in a Sierra EM7565 and it works fine. I’ve also tried a Telit FN980m and it also works fine. But the Quectel card does not work.

If I put the Quectel card into a USB3 adapter board, it works perfectly, but it will not work in the m.2 slot. It is not enumerated by the USB bus at all. Has anyone run into a problem like this?


Dear Jeff,
Thanks for your question. Please check hardware schematic with your M.2 slot board first. Here are the pin definition, thanks!

Here is the B-key slot diagram of the motherboard I’m using. I verified with an oscilloscope that the voltage drop and voltage ripple are within the required ranges.

VCC on this board is 3.3V. Will this prevent the modem from working properly? I attached a UART to USB converter to the debug pads beneath the modem. When the modem is plugged in via USB adapter I get the usual startup sequence displayed on the serial output. When the modem is plugged into the motherboard on the B-key slot, I get no output at all.

Dear Sir,
Do you use USB interface? If yes, please keep all pins open except USB interface, VCC, GND, SIM card and Full_Card_Power_Off, then have a try, you also can take a picture about your test environment. Thanks!

That worked! Thank you so much!

I removed all PCI and SATA related signals, and the card works now.